[Settings][Wallpaper] Set Cropped Gallery Image will display in Settings uncropped initially

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], [Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8613145 [details]
logcat_20150529_1543.txt

Description:
When a user changes the wallpaper of their phone in Settings with an image from their Gallery, if they crop they image before setting: the image will be revealed in the wallpaper preview as full without being cropped and off-center initially before flashing and changing to it's set cropped state. 
* Does not appear to occur when images cropped were taken from Camera


PreReq:
* images placed on phone, not taken from Camera
Repro Steps:
1) Update a Flame to 20150529010201
2) Open Settings app
3) Navigate to Display
4) Tap Preview to change Wallpaper with image from Gallery
5) Select image from gallery and crop it, hit done
6) Observe Wallpaper Preview

Actual:
Image displays in full initially, changes to cropped state after a moment

Expected:
Image displays in preview as cropped state set by user


Environmental Variables:
-------------------------------

Device: Xperia Z3 Compact (B2G)
BuildID: 20150528210322
Gaia: 18f7c340f970991a10c288310bbfd4d105a1430c
Gecko: b7aed25b94251ea192021885323f15e87fc39321
Version: 41.0a1 (3.0) 

Device: Flame 3.0
Build ID: 20150529010201
Gaia: e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gecko: f986e55c4e0b
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame 2.2
BuildID: 20150529002502
Gaia: a57ec5786c9f941c690266bbb26049dbb8482b05
Gecko: 6e9875ef5297
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

**********************************

Issue DOES NOT REPRO on 2.1 for flame devices
Results: Image reveals as cropped in Preview immediately

Device: Flame 2.1
BuildID: 20150529001200
Gaia: 2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gecko: 894528758073
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-------------------------------


Repro frequency: 5/7
See attached: 
video- https://youtu.be/7KRDTS9BeUw
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Visible regression, poor UX.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Contact: jthomas

Comment 2

3 years ago
Mozilla Inbound Regression Window

First Working
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520183146
Gaia: 5a7f87b1505ba89b586372cbbbe9507d1016c40c
Gecko: 1f6a0d225927
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


First Broken
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520185539
Gaia: 5a7f87b1505ba89b586372cbbbe9507d1016c40c
Gecko: edddd285c20c
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko.
Gaia: 5a7f87b1505ba89b586372cbbbe9507d1016c40c
Gecko: edddd285c20c

First Broken gaia / Last Working gecko - This issue does NOT occur with working Gecko.
Gaia: 5a7f87b1505ba89b586372cbbbe9507d1016c40c
Gecko: 1f6a0d225927

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1f6a0d225927&tochange=edddd285c20c


Issue appears to occur due to changes made in Bug 1154974
Blocks: 1154974
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
John, let's get the window for the slight shift and flicker when cropping that affects 2.2 as well.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(jthomas)

Comment 4

3 years ago
Sure thing. My window for the cropped image reverting back to the center of the image horizontally is correct. However, there is still some movement of the image in the preview after it has been cropped and set adjusting downwards slightly afterwards. This dates back as far as the base to Jellybean.
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(jthomas) → needinfo?(ktucker)
Seth, can you take look at this please? This might have been caused by the work done for bug 1154974.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(seth)
There's a patch up already in bug 1169680.
Depends on: 1169680
Flags: needinfo?(seth)

Comment 7

2 years ago
set qawanted to verify if it fixed
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: jthomas → pcheng
This issue appears to be fixed on Flame and Aries.

However I observed the cropped preview seems to shift a little bit within the preview window after setting it. On 2.2 this shifting comes with a flickering of the preview window so it looks worse. I'll look into bugging this separately.

Device: Aries 2.5
BuildID: 20150806111958
Gaia: 497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gecko: 22476236b3e1
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
BuildID: 20150806103226
Gaia: 497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gecko: 2fad09a0540d
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2
BuildID: 20150806032503
Gaia: f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gecko: a9379f716e9f
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Uh, never mind the issue I was observing was mentioned in comment 4 by John already: "However, there is still some movement of the image in the preview after it has been cropped and set adjusting downwards slightly afterwards. This dates back as far as the base to Jellybean."
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.