Recompute image visibility when display port margins change

RESOLVED FIXED in Firefox 41

Status

()

defect
RESOLVED FIXED
4 years ago
8 months ago

People

(Reporter: seth, Assigned: seth)

Tracking

unspecified
mozilla41
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox41 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
During scrolling, display port margins can go through large changes. A fast fling can produce a display port that's 10,000 CSS pixels high or more! Those huge display ports do get shrunk back down once scrolling stops or slows down, but we currently don't have any way of updating image visibility information when that happens.

Let's add code to update image visibility information when display port margins change.
(Assignee)

Comment 1

4 years ago
Here's the patch. So easy!
Attachment #8613201 - Flags: review?(tnikkel)
Attachment #8613201 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/7a609d5e44a3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
(Assignee)

Comment 5

4 years ago
Comment on attachment 8613201 [details] [diff] [review]
Recompute image visibility when display port margins change

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Not sure, but it was exposed by the fact that we enabled image locking on B2G in bug 1148696.
User impact if declined: Images may fail to decode due to low memory, causing blank thumbnails in the gallery which may persist across reboots (making this effectively a data loss issue). This patch is one of several that together fix bug 1166136, which is nominated for blocking 2.2, and bug 1164164, which is a 2.2 blocker.
Testing completed: Extensively tested locally. On mozilla-central.
Risk to taking this patch (and alternatives if risky): This is a very simple, low risk patch.
String or UUID changes made by this patch: None.
Attachment #8613201 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
blocking-b2g: --- → 2.2+

Updated

4 years ago
Attachment #8613201 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Depends on: 1241371

Updated

8 months ago
Product: Core → Core Graveyard

Updated

8 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.