iMacros for Firefox add-on doesn't work properly with FF 38.0.1

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: matthew.hitching, Unassigned)

Tracking

({addon-compat, regression})

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

4 years ago
Posted image FF bug.PNG
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

In iMacros for Firefox (I'm using the latest v. 8.9.2) I have a macro which logs into my broadband router, changes some settings and then logs out.  It worked fine before I upgraded FF to 38.0.1 but in 38.0.1 the macro doesn't work any more.




Actual results:

The macro hangs when trying to fill in the user and password in the 'Authentication Required' popup window.  Attached file shows the window.  The macro is below:

TAB T=1
SET !ENCRYPTION NO
ONLOGIN USER=****** PASSWORD=****** (I masked these for this report)
URL GOTO=http://192.168.0.1/sky_firewall_rules.html
...
TAG POS=1 TYPE=A ATTR=TXT:Logout 

The login works fine manually using FF - it's just the macro that hangs.  

I tried to re-record the macro, in case the issue was that the router was asking for different login information, e.g. due to an upgrade of its firmware, but then iMacros failed even to record the login actions (user name and password) at all, something it could definitely do before.

I downgraded FF to 37.0.2 and the macro works and it can also record the login actions properly again, so I think the issue is with FF 38.0.1, not iMacros for Firefox.


Expected results:

1. The existing macro should have been able to fill in the details in the 'Authentication Required' popup window.
2. iMacros should be able to record the login actions (user name and password) on this kind of popup window.

Comment 1

4 years ago
(In reply to matthew.hitching@sky.com from comment #0)
> In iMacros for Firefox (I'm using the latest v. 8.9.2)

The latest version is 8.9.2.1-signed. Is that what you meant? If not, please update and test again.

Please check if the problem also occurrs with the following build:
https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015/01/2015-01-23-03-02-03-mozilla-central/firefox-38.0a1.en-US.win32.zip
Component: Untriaged → Extension Compatibility
Flags: needinfo?(matthew.hitching)
Keywords: addon-compat
Reporter

Comment 2

4 years ago
(In reply to Gingerbread Man from comment #1)
> (In reply to matthew.hitching@sky.com from comment #0)
> > In iMacros for Firefox (I'm using the latest v. 8.9.2)
> 
> The latest version is 8.9.2.1-signed. Is that what you meant? If not, please
> update and test again.
> 
> Please check if the problem also occurrs with the following build:
> https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015/01/2015-01-23-
> 03-02-03-mozilla-central/firefox-38.0a1.en-US.win32.zip

Thanks for quick reply Gingerbread Man.

I am using 8.9.2.1-signed.

I installed the build in the link you sent.  Same problem occurs when I run my macro.
Flags: needinfo?(matthew.hitching)
Have you tried contacting the developer? There's contact information on the add-on listing page: https://addons.mozilla.org/addon/imacros-for-firefox/

Comment 4

4 years ago
(In reply to matthew.hitching@sky.com from comment #2)
> I installed the build in the link you sent.  Same problem occurs when I run
> my macro.

Thank you for the update.

There was a change relating to basic authentication in bug 1120233; I thought that might've caused the regression.

I can't reproduce this with the aforementioned 2015-01-23 build or the 2015-06-01 Nightly (non-e10s only; bug 1147327) and following macro:
―――――――
VERSION BUILD=8920312 RECORDER=FX
TAB T=1
ONLOGIN USER=username PASSWORD=password
URL GOTO=http://dolske.net/mozilla/tests/httpauth/realmX
―――――――
Reporter

Comment 5

4 years ago
Thanks, Gingerbread Man.  Shall I try the macro in comment #4 on the build you mentioned in comment #1?

I'm not sure if it's relevant but one difference I can think of is that my router and the computer I'm running FF + the macro are on my LAN.  Could that affect the basic authentication?  Also, I think the router may be using micro httpd http://acme.com/software/micro_httpd/  I'm not sure if that can help you reproduce the problem.
Reporter

Comment 6

4 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #3)
> Have you tried contacting the developer? There's contact information on the
> add-on listing page: https://addons.mozilla.org/addon/imacros-for-firefox/

Thanks, Jorge.  Will do.  I contacted Bugzilla in the first place because the macro worked on past versions of FF up to 38.0.1 so I don't think the problem is with the add-on.  But perhaps the add-on developer may have some ideas...

Comment 7

4 years ago
(In reply to matthew.hitching@sky.com from comment #5)
> Thanks, Gingerbread Man.  Shall I try the macro in comment #4 on the build
> you mentioned in comment #1?

If you could try it in Firefox 38.0.1, it would be interesting to know if the dialog box is filled out and submitted, or if it hangs around as with your other macro.
Reporter

Comment 8

4 years ago
(In reply to Gingerbread Man from comment #7)
> (In reply to matthew.hitching@sky.com from comment #5)
> > Thanks, Gingerbread Man.  Shall I try the macro in comment #4 on the build
> > you mentioned in comment #1?
> 
> If you could try it in Firefox 38.0.1, it would be interesting to know if
> the dialog box is filled out and submitted, or if it hangs around as with
> your other macro.

Hi Gingerbread Man, I tried the macro in comment #4 in the build in comment #1. It doesn't hang but it can't authenticate either.  The message I get is 

"Authorization Required

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Could this message indicate iMacros is filling out the dialog box and submitting it as expected but the credentials (username+password) it's filling out are just invalid?  I think that might be the case because I can't log in manually with these credentials either.

I get the same result running this test macro in FF 37.0.2 too.

Comment 9

4 years ago
(In reply to matthew.hitching@sky.com from comment #8) 
> Hi Gingerbread Man, I tried the macro in comment #4 in the build in comment
> #1. It doesn't hang

Thanks for the update.

Then it would seem the problem is specific to the router page, so I can't test further. iMacros support is probably your best bet to finding out what's up.

It might be helpful to find the regression range; that might point to a bug that could've regressed this functionality.

mozregression --good-release 37 --bad-release 38
http://mozilla.github.io/mozregression/

Also, any relevant errors in the Browser Console could help.
https://developer.mozilla.org/en-US/docs/Tools/Browser_Console

> but it can't authenticate either.

That's normal, since both the username and password are incorrect. The point was just to check if iMacros submits the information in the basic authentication dialog.
Reporter

Comment 10

4 years ago
Reporter

Comment 11

4 years ago
(In reply to Gingerbread Man from comment #9)
> (In reply to matthew.hitching@sky.com from comment #8) 
> > Hi Gingerbread Man, I tried the macro in comment #4 in the build in comment
> > #1. It doesn't hang
> 
> Thanks for the update.
> 
> Then it would seem the problem is specific to the router page, so I can't
> test further. iMacros support is probably your best bet to finding out
> what's up.
> 
> It might be helpful to find the regression range; that might point to a bug
> that could've regressed this functionality.
> 
> mozregression --good-release 37 --bad-release 38
> http://mozilla.github.io/mozregression/
> 
> Also, any relevant errors in the Browser Console could help.
> https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
> 
> > but it can't authenticate either.
> 
> That's normal, since both the username and password are incorrect. The point
> was just to check if iMacros submits the information in the basic
> authentication dialog.

Hi Gingerbread Man, sorry for the late reply.  I will try iMacros support.

I did use mozregression and found that the bug was introduced in FF on January 14, 2015 (last good version was January 13, 2015).  I attached a screeenshot with the result.

I tried the Browser Console too but couldn't make much sense of information - just seemed to confirm a HTTP/1.1 401 Unauthorized error.  Also lots of warnings about the site making use of a SHA-1 Certificate but I guess that's just because the router uses relatively simple security.

I do have a second router on my network and tried the macro on that router too with the same result - it hangs.  If you were looking to replicate the error maybe you could try using iMacros add-on to log in to a router on your own network?

One other thing I found is that the same macro works fine with iMacros add-on for IE, using what I think is the most recent version of IE.
Reporter

Comment 13

4 years ago
(In reply to Gingerbread Man from comment #12)
> Thank you for the update.
> 
> Push log:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=3d846527576f&tochange=63006936ab99

After I posted on the iMacros for FF forum I was told that there was another user with the same issue.  I eventually tracked down a thread started by KingTutt on June 4 at http://forum.imacros.net/viewtopic.php?f=11&t=7044&p=64077#p64095

The issue seems to be the same one but the website https://www.flugwetter.de/ is accessible if you want to take a look.  When you click on a Login button an 'Authentication Required' window pops up just like with my router.

The issue appears to be being looked at by iMacros support but no solution as of today.
Reporter

Comment 14

4 years ago
Just to add that my macro doesn't work with FF 39.0.1 either.
It looks like this issue has been fixed on the iMacros side.

Comment from http://forum.imacros.net/viewtopic.php?f=11&t=7044&start=315

"iMacros for Firefox 8.9.4 has been fully reviewed by Mozilla and is now available in the Firefox add-ons gallery (https://addons.mozilla.org/en-US/firefox/addon/imacros-for-firefox/)."

I will close this issue as WFM.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.