It takes a long time to paint the mozilla.org page because of scaled tiled images

RESOLVED FIXED in Firefox 40

Status

()

Core
Graphics
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mconley, Assigned: mchang)

Tracking

(Blocks: 2 bugs, {regression})

Trunk
mozilla41
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 affected, firefox40+ fixed, firefox41+ fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

STR (non-e10s);

1) Visit mozilla.org in a tab
2) Open a second tab, and visit about:blank in it
3) Switch back to the mozilla.org tab

ER:

Nearly-instantaneous switching to the mozilla.org tab

AR:

~2s delay before the tab switches, before which the whole browser janks.

Here's a profile (ignore the content process - again, this was done in a non-e10s window):

https://people.mozilla.org/~sguo/cleopatra/#report=3e45f228f6c9e9d9deb92111715d900db6797825&selection=0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,153,154,155,156,214,215,216,217,218,219,220,221,420,1037,1038,1039,1039,1040,1041,1042,1043,1044,1045,237,238,239,240,766,242,243,244,767,1046,1047,1048,1049,1050,1051,1052,1053,1054,1055,1056,1057,773,229,230,231,329,331,332,333,249,250,251,252,253,254,255,1513
Note that attempting this with e10s enabled causes the content process to hang for approximately the same amount of time. As one would expect, the main browser UI remains responsive, but we get big fat spinners in the content area.
Summary: It takes a long time to paint the mozilla.org page → It takes a long time to paint the mozilla.org page because of scaled tiled images
Keywords: regressionwindow-wanted
Last good nightly: 2015-04-20
First bad nightly: 2015-04-21

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2015-04-20&enddate=2015-04-21

jrmuizel puts his bet squarely on http://hg.mozilla.org/mozilla-central/rev/2d97da8feb72.

I can try to confirm this tomorrow.
Flags: needinfo?(mconley)
Keywords: regressionwindow-wanted
(Assignee)

Updated

3 years ago
See Also: → bug 1154311
(Assignee)

Updated

3 years ago
Blocks: 1154825
[Tracking Requested - why for this release]: This is a major unexpected performance regression.
tracking-firefox40: --- → ?
tracking-firefox41: --- → ?
(Assignee)

Comment 4

3 years ago
Created attachment 8615483 [details] [diff] [review]
Backout bug 1073209 - Reinstate CSRD on OS X

Since I haven't had time to invest in bug 1154311, and removing CSRD on OSX has caused this plus bug 1164601, add CSRD back to OS X for now to fix the regressions.
Attachment #8615483 - Flags: review?(jmuizelaar)
Comment on attachment 8615483 [details] [diff] [review]
Backout bug 1073209 - Reinstate CSRD on OS X

Review of attachment 8615483 [details] [diff] [review]:
-----------------------------------------------------------------

:(
Attachment #8615483 - Flags: review?(jmuizelaar) → review+
I can confirm that this backout makes things better on my machine.
Blocks: 1073209
Flags: needinfo?(mconley)

Comment 8

3 years ago
Landed yesterday - https://hg.mozilla.org/mozilla-central/rev/baeb37ae48d2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
I tracked for 40 and 41, due to the performance regression, but if I understand correctly this is now fixed.
tracking-firefox40: ? → +
tracking-firefox41: ? → +
Keywords: regression
Assignee: nobody → mchang
Hey mchang - can I assume we'll want this to land on Aurora as well?
Flags: needinfo?(mchang)
(Assignee)

Comment 11

3 years ago
Created attachment 8621144 [details] [diff] [review]
aurora backout patch

Backout patch rebased for aurora.
Flags: needinfo?(mchang)
Attachment #8621144 - Flags: review+
(Assignee)

Comment 12

3 years ago
Comment on attachment 8621144 [details] [diff] [review]
aurora backout patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1073209 on OS X.
[User impact if declined]: Performance regression with scaled background images.
[Describe test coverage new/current, TreeHerder]: Mochitests / reftests  / manual testing.
[Risks and why]: Low: CreateSamplingRestrictedDrawable has been in firefox for a very long time. Bug 1073209 deleted it on OS X, which caused performance regressions. This reinstates CreateSamplingRestrictedDrawable 
[String/UUID change made/needed]: None
Attachment #8621144 - Flags: approval-mozilla-aurora?
status-firefox39: --- → affected
Comment on attachment 8621144 [details] [diff] [review]
aurora backout patch

Important regression, taking it.
Attachment #8621144 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.