Crash when starting debug build with -ProfileManager

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
--
critical
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mikedeboer, Unassigned)

Tracking

({crash, regression})

Trunk
x86_64
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(firefox41 affected)

Details

Terminal output:

./obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/firefox-bin -ProfileManager
[55072] WARNING: '!compMgr', file /Users/mikedeboer/Projects/fx-team/xpcom/glue/nsComponentManagerUtils.cpp, line 63
Assertion failure: SingletonExists(), at ../dist/include/gfxPrefs.h:208
#01: nsWindowWatcher::CalculateChromeFlags(nsIDOMWindow*, char const*, bool, bool, bool, bool, bool)[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x2eca8a2]
#02: nsWindowWatcher::OpenWindowInternal(nsIDOMWindow*, char const*, char const*, char const*, bool, bool, bool, nsITabParent*, nsIArray*, nsIDOMWindow**)[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x2ec712e]
#03: nsWindowWatcher::OpenWindow(nsIDOMWindow*, char const*, char const*, char const*, nsISupports*, nsIDOMWindow**)[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x2ec62bb]
#04: ShowProfileManager(nsIToolkitProfileService*, nsINativeAppSupport*)[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x324a091]
#05: XREMain::XRE_mainStartup(bool*)[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x3244618]
#06: XREMain::XRE_main(int, char**, nsXREAppData const*)[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x3248bc6]
#07: XRE_main[/Users/mikedeboer/Projects/fx-team/obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/XUL +0x324910a]
#08: main[/Users/mikedeboer/Projects/fx-team/./obj-x86_64-apple-darwin14.3.0/dist/NightlyDebug.app/Contents/MacOS/firefox-bin +0x2145]
Segmentation fault: 11

I'm filing this as an OSX bug, because I didn't see this issue occur on another platform.

I'm using OSX 10.10.3.

This bug is currently preventing me from creating new profiles for Fx development.
I see this too, in today's mozilla-central-debug nightly.  I also get an OS X crash stack -- but it's completely useless, since (for reasons I've never understood) our debug nighties' symbols are stripped :-(

It'd really help if you could find the regression range in mozilla-central-debug nightlies.
Does this still reproduce, Mike?
Flags: needinfo?(mdeboer)
Nope! Thanks for the ping, Ryan.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mdeboer)
Resolution: --- → FIXED
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.