"Unknown socket type. Loading aborted" when trying to access SSL'ed site

VERIFIED DUPLICATE of bug 47617

Status

()

VERIFIED DUPLICATE of bug 47617
17 years ago
17 years ago

People

(Reporter: jakub, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226
BuildID:    2001122617

loading stops at Alert: "Unknown socket type. Loading aborted" immediately after
trying to access any url starting with https://

Reproducible: Always
Steps to Reproduce:
1. write https://somesite to location bar
2. <enter>


Actual Results:  Alert "Unknown socket type. Loading aborted" appears

Expected Results:  it should load the SSL'ed page
The message should really say "In order to view SSL sites, you need to have PSM
installed" or something similar.

If you installed from RPM, you also need the mozilla-psm package.  Otherwise,
re-install and don't uncheck PSM this time around.

*** This bug has been marked as a duplicate of 47617 ***
Severity: blocker → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Where can one find this PSM bit?

Comment 3

17 years ago
I think there were some instrunctions on http://www.mozilla.org on building psm
into mozilla.   The other alternative is to download a recent nightly build and
it should be installed.

Comment 4

17 years ago
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.