Disable retrigger/cancel requests to buildapi on the ash branch

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: adusca, Assigned: KWierso)

Tracking

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
emorley
: review+
Details | Review
Reporter

Description

4 years ago
We would like to test using pulse_actions for retrigger/cancel requests in the ash branch.

For this, treeherder would have to keep sending pulse messages to exchange/treeherder/v1/job-actions but stop doing the actual request to buildapi just in the ash branch.

According to :emorley (in bug 1168148 comment 20), 

> you'll just need a conditional on $scope.repoName, wrapping:
> https://github.com/mozilla/treeherder/blob/9da6ddbf4151436f20a763d9543b86409214d8c3/ui/plugins/controller.js#L274-L277
> ...which will stop just the buildapi retrigger, but not the treeherder API POST that then results in the pulse message.
Reporter

Updated

4 years ago
Blocks: 1168148
Assignee

Comment 1

4 years ago
Posted file PR 606
If that's all it needs, this should do it.
Attachment #8614474 - Flags: review?(emorley)
Assignee: nobody → wkocher
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8614474 [details] [review]
PR 606

Have left a couple of comments on the PR - thank you for grabbing this bug :-)
Attachment #8614474 - Flags: review?(emorley)
Blocks: 1077053
Assignee

Comment 3

4 years ago
Comment on attachment 8614474 [details] [review]
PR 606

I think this is what you were asking for? Also, do I need to do the same thing for the "cancelAll" case just below the retrigger and cancel cases?
Attachment #8614474 - Flags: review?(emorley)
Comment on attachment 8614474 [details] [review]
PR 606

Looks good, thank you :-)
Attachment #8614474 - Flags: review?(emorley) → review+
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/fcbab21294ec7ae964d00ac9a1b68cf31a10177b
Bug 1170839 - Don't send retrigger/cancel requests for the ash repository r=emorley

https://github.com/mozilla/treeherder/commit/bf8701b15e9c110a17754dd73c99dade901a642c
Merge pull request #606 from KWierso/1170839

Bug 1170839 - Disable retrigger/cancel requests to buildapi on the ash branch r=emorley
Assignee

Comment 6

4 years ago
Ed via IRC says the cancelAll stuff can wait for bug 1171575, so I went ahead and merged this part at least.

Unsure when the next merges to stage/prod will happen for this to get deployed for :adusca and others to use for testing on Ash.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Is this live now?
(In reply to Armen Zambrano G. (:armenzg - Toronto) from comment #7)
> Is this live now?

The deployed Treeherder revision can be found in https://treeherder.mozilla.org/media/revision (listed at the bottom of the Treeherder help page, linked on the Treeherder menu bar). The current rev is:
https://github.com/mozilla/treeherder/commit/4bafb7c9c620f7b5b86185f47dcf5820744e9c51

Doing:
https://github.com/mozilla/treeherder/compare/<deployed>...<commit-of-interest>
...will tell you whether a commit is deployed or not (if that URL comes back empty, then it's deployed).

ie:
https://github.com/mozilla/treeherder/compare/4bafb7c9c620f7b5b86185f47dcf5820744e9c51...fcbab21294ec7ae964d00ac9a1b68cf31a10177b

-> "There isn't anything to compare."

So this is in production.
Thanks for the explanation!
Reporter

Comment 10

4 years ago
I tested retriggering and then cancelling a job today on ash through TH and it still works. Is there something else that needs to be done?
Flags: needinfo?(emorley)
Reporter

Comment 11

4 years ago
It seems the minified JS files were only updated in commit
https://github.com/mozilla/treeherder/commit/b5f5f04281b1eab533f98ee7bde170801c09a188

I used your method to check if the above commit is already deployed and it isn't. So that explains it.
Flags: needinfo?(emorley)
(In reply to Alice Scarpa [:adusca] from comment #11)
> It seems the minified JS files were only updated in commit
> https://github.com/mozilla/treeherder/commit/
> b5f5f04281b1eab533f98ee7bde170801c09a188

Ah sorry grunt build is supposed to be run before deploying, looks like that was omitted last time a deploy was performed. Sorry for the confusion!
Reporter

Comment 13

4 years ago
Do you know when the next TH deployment is planned to happen?
Flags: needinfo?(emorley)
A deploy with an updated grunt build was done this evening, sorry for the delay :-)
Flags: needinfo?(emorley)
Hi,
Can we revert this change?

Until bug 1032163 is fixed pulse_actions won't handle retriggers and cancels.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Let's do this in a new bug please - easier to track.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Blocks: 1215316
You need to log in before you can comment on or make changes to this bug.