Mac application menu empty in some circumstances

RESOLVED DUPLICATE of bug 1151345

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1151345
3 years ago
3 years ago

People

(Reporter: Ben Schmidt, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

I have two reproduction scenarios. Using both these scanarios, FF 37.0.2 is known good and 38.0.5 known bad. 38.0.1 I believe was bad also, but not 100% sure. I am using the en-GB localised Mac versions.

SCENARIO 1:
1. Open Mac Firefox
2. "Restart with Add-ons Disabled"
3. "Restart"
4. "Start in Safe Mode"
5. Open Mac application menu ("Firefox", beside Apple menu)

SCENARIO 2:
1. Install FoxyProxy Standard 4.5.5 into Mac Firefox from https://addons.mozilla.org/en-us/firefox/addon/foxyproxy-standard/
2. Restart Firefox
3. Navigate to FoxyProxy's preferences.
4. "Add New Proxy"
5. "Automatic Proxy Configuration"
6. For automatic proxy configuration URL enter "http://localhost/dummy.pac"
7. "OK"
8. Select mode: "Use proxy 'New Proxy' for all URLs"
9. "Close"
10. Close Firefox
11. Reopen Firefox; notification "FoxyProxy PAC Status" should appear on screen during startup
12. Open Mac application menu ("Firefox", beside Apple menu)



Actual results:

Only item in application menu is "Quit"


Expected results:

Full application menu including "About Firefox", "Preferences…", "Services", "Hide Firefox", "Hide Others", "Show All", "Quit Firefox".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151345
> SCENARIO 2:

I can reproduce this in Firefox 38.0.5, but not in the latest FF 39 beta (beta 6).

Which is puzzling, because my patch for bug 1151345 will only get into FF 39 beta 7.
I'm not able to test with FF 41 (mozilla-central) or FF 40 (mozilla-aurora, aka the Developer Edition). FoxyProxy refuses to install on either of these.
You need to log in before you can comment on or make changes to this bug.