slashdot favico doesn't work.

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Wilfried Goesgens, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
the Icon left of the url apears. Other favicos work. is it pherhaps about that 
I named the bookmark '/.'? How does it calculate the filename?
Should this be way of 'url-encoded'?

Comment 1

17 years ago
Seems to WFM.

Does the icon reappear after follow the bookmark?
Wilfried, please be more specific.  First what build are you running, second
what exactly do you mean by it doesn't work?  Third, have a look at
http://www.mozilla.org/quality/bug-writing-guidelines.html to make it easier on
you (less questions to answer) and us (less questions to ask)

Thanks :)

Comment 3

17 years ago
I think I can help here.

If you go to http://www.slashdot.org/, you get redirected to
http://slashdot.org/. http://slashdot.org has a favicon,
http://www.slashdot.org/ does not. So if you have a bookmark pointing to
http://slashdot.org/ the favicon will be displayed, but if the bookmark points
to http://www.slashdot.org/ it won't be.

Simple, really. :-)

Wilfried, could you please confirm whether or not this is the case?
(Reporter)

Comment 4

17 years ago
first, im running 0.9.7.
second, I have an existing bookmarkset, It contains also a link to
wvww.slashdot.org, as well as to e.g. www.freshmeat.net. I lately upgraded from
0.9.5 to 0.9.7. The slashdot bookmark is in the personal-toolbar-folder next to
the freshmeat one. left of the /. there is a seperator.
After upgrading to 0.9.7, the favicos were loaded as I hit a matching website
and shown left in the url-line. The /. Icon was also shown there. Usualy if
icons were in the Url-line and in the bookmarks, the Favico was shown in the
bookmarks too, (like freshmeat) but not /.  . My Idea analyzing the ./-bookmark
was, that it contains a unix-special character, the '/', and if there would be
build a filename of that string, it would fail in any case. 
So I thought that it should be way of url-encoded.
detailed enough?
The 2nd poster: yes, the bookmark is ....org/; but the url-line if I hit the
bookmark too. And it loads the Icon. Anyway, I can't change my bookmarks,
because of I'm getting empty context-menu's at the moment.

Comment 5

17 years ago
->hyatt
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh

Comment 6

17 years ago
To explain the problem here once again:

If your bookmark is www.slashdot.org (notice the www.) you'll see no favicon,
because www.slashdot.org provides no favicon; you'll only be redirected to
slashdot.org (without www.).

If your bookmark points to slashdot.org (again, without www.), everything works
fine, at least for me.
hyatt
Assignee: pchen → hyatt
QA Contact: sairuh → claudius
*** Bug 118158 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Well, my /. bookmark points to slashdot.org and is one of the few favicons that
has truly been reliable.  I'm running 2002012606 on Linux.  So... WFM.

Comment 10

16 years ago
Resolving as Works for me.
Please reopen, if you still see this with a bookmark pointing to
http://slashdot.org (and not http://www.slashdot.org !!)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.