Sync doesn't run if there is a login error at startup

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: markh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
If browserid_identity initializes and finds a network error during initialization, Sync doesn't start a regular schedule - it just does nothing. It should start a regular schedule in the hope/expectation the network error was transient.  (Note that if a manual sync is triggered, the schedule does then runs as normal)

This first sync is initiated by delayedAutoConnect() in policies.js, which calls autoConnect() on a timer. autoConnect() will only perform that first sync if the "status" is OK, but at this point it's error.login.failed.

I believe the correct fix here is to make browserid_identity not do those login actions on initialization, but wait for an explicit login (which is done before a sync) - it only logs in on init due to hysterical raisins. A minor complication here may be the "choose what to sync" functionality, but I'm sure we can work that out.
(Reporter)

Comment 1

2 years ago
I'll see if this still exists.
Flags: needinfo?(markh)
(Reporter)

Comment 2

a year ago
I can no longer reproduce this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(markh)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.