fontconfig platform fontlist does not distinguish between italic and oblique

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Pim Blokland, Assigned: jtd)

Tracking

(4 keywords)

41 Branch
x86_64
Linux
fonts, regression, reproducible, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 unaffected, firefox41- unaffected, firefox42- unaffected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8614572 [details]
Screenshot of SeaMonkey 2.38a1 (trunk; Gecko rv:41)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 SeaMonkey/2.38a1
Build ID: 20150603003002

Steps to reproduce:

Using a font that has both italic and oblique styles (such as Kinnari), display the following HTML:

<!DOCTYPE html>
<html>
 <head>
  <meta charset="UTF-8">
  <title>Test of Kinnari font</title>
 </head>
 <body style="font:30px/36px 'Kinnari'">
  <div>This is Kinnari regular.</div>
  <div style="font-style:oblique">This is Kinnari oblique.</div>
  <div style="font-style:italic">This is Kinnari italic.</div>
 </body>
</html>


Actual results:

The bottom two lines are displayed in the same font, Kinnari Oblique


Expected results:

The bottommost line is supposed to be displayed in Kinnari Italic, just like in Gecko versions up to 40.
(Reporter)

Comment 1

3 years ago
Created attachment 8614574 [details]
Screenshot of SeaMonkey 2.33.1 (current release, Gecko rv:36)
(Reporter)

Updated

3 years ago
Attachment #8614574 - Attachment description: Screenshot of SeaMonkey 2.3 → Screenshot of SeaMonkey 2.33.1 (current rellease, Gecko rv:36)

Comment 2

3 years ago
Created attachment 8614673 [details]
testcase in description.html

Works
Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
20150602004005

Fails
Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
20150603030208

e10s status made no difference. Linux Mint KDE 17.1.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Text
Ever confirmed: true
Keywords: fonts, regressionwindow-wanted, reproducible, testcase
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
I'd guess this may be a result of bug 1056479.
Blocks: 1056479
[Tracking Requested - why for this release]: Font rendering regression
tracking-firefox41: --- → ?
Keywords: regressionwindow-wanted → regression
(Reporter)

Updated

3 years ago
Attachment #8614574 - Attachment description: Screenshot of SeaMonkey 2.33.1 (current rellease, Gecko rv:36) → Screenshot of SeaMonkey 2.33.1 (current release, Gecko rv:36)
(Assignee)

Updated

3 years ago
Summary: The browser no longer distinguishes between italic and oblique → fontconfig platform fontlist does not distinguish between italic and oblique
(Assignee)

Updated

3 years ago
Assignee: nobody → jdaggett
(Assignee)

Comment 5

3 years ago
Shouldn't be hard to add oblique matching. We skipped this because older API's didn't distinguish between italic/oblique but I think DirectWrite and fontconfig do, so it would be good to add this to the style matching code.
Tracked for 41 to ensure both italic and oblique styles render properly.
tracking-firefox41: ? → +
status-firefox40: --- → unaffected
status-firefox41: --- → affected
status-firefox42: --- → affected
tracking-firefox42: --- → +

Comment 7

3 years ago
John, I am trying to follow up on FF41+ tracked bugs. Is this something that you are considering fixing for 41? If yes, it would be good if the patch is ready and uplifted by Beta6. Beyond that it would be tough to take any fixes unless the end-user impact is very high. Thanks.
Flags: needinfo?(jdaggett)
(Assignee)

Comment 8

3 years ago
The use of the fontconfig platform fontlist is disabled for beta/release builds so this should not be tracked for FF41.
Flags: needinfo?(jdaggett)

Comment 9

3 years ago
FF41- based on comment 8. It is still tracked for 41. Perhaps someone should start investigating soon while 42 is in Aurora cycle.
tracking-firefox41: + → -
John, is it also disabled in 42? Thanks
Flags: needinfo?(jdaggett)
(Assignee)

Comment 11

3 years ago
(In reply to Sylvestre Ledru [:sylvestre] from comment #10)
> John, is it also disabled in 42? Thanks

Nothing at this point has changed, beta/release builds do not use the fontconfig platform fontlist path. I have a patch for this in progress so when this should already be fixed whenever we remove the beta/release restriction.
Flags: needinfo?(jdaggett)
(Assignee)

Updated

3 years ago
Depends on: 543715
(Assignee)

Comment 12

3 years ago
This will be fixed by the more general bug, bug 543715.
OK, Updating the tracking flags accordingly.
status-firefox41: affected → unaffected
status-firefox42: affected → unaffected
tracking-firefox42: + → -
(Assignee)

Comment 14

3 years ago
Fixed by changes landed on bug 543715.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.