Closed Bug 1170955 Opened 5 years ago Closed 3 years ago

Reader Mode: Give visited links a different colour

Categories

(Toolkit :: Reader Mode, enhancement, P2)

38 Branch
enhancement

Tracking

()

VERIFIED FIXED
mozilla51
Tracking Status
firefox51 --- verified

People

(Reporter: gerhard.grossmann, Assigned: rakhisharma)

References

(Blocks 1 open bug)

Details

(Whiteboard: [about-reader-ui])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511103818

Steps to reproduce:

For some websites FF offers a reader mode since Version 38.0.5.


Actual results:

However the CSS for this mode lacks to differentiate visited and not yet visited links.


Expected results:

See http://joelcalifa.com/blog/revisiting-visited/ why distinctive colours help the user to navigate.
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Whiteboard: [about-reader-ui]
Blocks: 1286221
Assignee: nobody → Rakhish1994
Comment on attachment 8782389 [details]
Bug 1170955 - Reader Mode: Give visited links a different color. .

https://reviewboard.mozilla.org/r/72574/#review70210

::: toolkit/themes/shared/aboutReaderContent.css:88
(Diff revision 1)
>    text-decoration: underline;
>    font-weight: normal;
>  }
>  
>  a,
> -a:visited,
> +a:link,

I think we should just remove the :visited line, and probably make sure all 3 remaining ones include ":link". Please do the same for the rule above (the one with text-decoration: underline and font-weight: normal). Right now anchors that are not links will also get underlines and get colored, which is not right.

::: toolkit/themes/shared/aboutReaderContent.css:94
(Diff revision 1)
> +a:visited {
> +  color: #609;
> +}

This color does not work well with the dark theme, maybe let's use #c2e which is a bit lighter, so there's more contrast? It still has >3:1 contrast with the light and sepia theme as well, so I think that works.
Attachment #8782389 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8782389 [details]
Bug 1170955 - Reader Mode: Give visited links a different color. .

https://reviewboard.mozilla.org/r/72574/#review70226

Looks good to me, thanks!
Attachment #8782389 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/33584a021edd
Reader Mode: Give visited links a different color. r=Gijs.
https://hg.mozilla.org/mozilla-central/rev/33584a021edd
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Duplicate of this bug: 1240035
QA Whiteboard: [good first verify]
The Reader Mode gives visited links a different colour.
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify] → [good first verify][bugday-2017-01-06]
You need to log in before you can comment on or make changes to this bug.