Regression: Tab count button becomes unresponsive for a second or two after opening a new tab

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: sleroux)

Tracking

({perf, regression, reproducible})

unspecified
ARM
iOS
perf, regression, reproducible

Firefox Tracking Flags

(fennec+, fxios+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Currently after opening a tab the tab count button to open the tab drawer becomes unresponsive for a second or two e.g, you want to open another tab quickly. Tapping the button does nothing until something in the background finishes.
Assignee: nobody → sleroux
tracking-fennec: ? → +
tracking-fxios: --- → +
(Assignee)

Comment 1

3 years ago
Created attachment 8614849 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/554

Tried a couple things to slim down the CPU cycles when the transition finishes. Let me know how this feels - I think it's feeling better now.
Attachment #8614849 - Flags: review?(bnicholson)
Attachment #8614849 - Flags: feedback?(aaron.train)
Comment on attachment 8614849 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/554

These changes look good to me, though I'm not sure if they'll fix this. I've actually noticed this before too (thanks Aaron for filing), and I think it's related to the clone button we create at [1] during the animation. It doesn't have a click listener, so it's untappable while it's active. A simple solution might be to just attach the same click listener to the cloned view?

It's a little strange that the animation is lasting as long as it is since I don't actually see any movement during this period.

[1] https://github.com/mozilla/firefox-ios/blob/master/Client/Frontend/Browser/URLBarView.swift#L301
Attachment #8614849 - Flags: review?(bnicholson) → review+
(Assignee)

Comment 3

3 years ago
Good catch -- I do notice the lag is longer whenever opening a new tab and it looks like it's probably because of the cloned button. I'll update the PR to add the selector to the fake button as well.
(Assignee)

Comment 4

3 years ago
Merged
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
Attachment #8614849 - Flags: feedback?(aaron.train) → feedback+
You need to log in before you can comment on or make changes to this bug.