Closed Bug 1171148 Opened 5 years ago Closed 3 years ago

Broken add-on install displayed in the add-ons manager after installs are cancelled by closing the original window/tab

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox40 + wontfix
firefox41 + wontfix
firefox42 - affected

People

(Reporter: mossop, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:
QA Contact: vasilica.mihasca
This happens when closing the tab while the add-on is downloading. My patch in bug 1147808 attempted to care of this, but lots of tests didn't like that, see bug 1147808 comment 7.
Attached patch old patchSplinter Review
here's that part of the patch that I didn't land
Adding a tracking flag for Firefox 40 and Firefox41 because this could be confusing from an end-user point of view if we indicate that an add-on is installed though it is in a busted "broken" state.

Dao, are you working on a fix? If yes, could you please assign this to yourself so we know it has an owner?

Vasilica, I have added the keyword "regression". Please let me know if this is not a regression.
Flags: needinfo?(vasilica.mihasca)
Flags: needinfo?(dao)
Keywords: regression
I'm not working on this and IMHO we don't necessarily need to track this, seems like an edge case.
Flags: needinfo?(dao)
This “Download box” also appears in about:addons for Firefox 4, when a tab is closed during the download process. But for Firefox versions, which use the old install flow, with tab-model prompt for the confirmation install, this “Download box” disappears when the tab-model is closed (“x” button) or Install/Cancel buttons are selected.

In the current Nightly/Aurora, the “Download box” from about:addons does not disappear because of the new add-on install flow, which replaced the tab-model with a doorhanger.
Flags: needinfo?(vasilica.mihasca)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #5)
> This “Download box” also appears in about:addons for Firefox 4, when a tab
> is closed during the download process. But for Firefox versions, which use
> the old install flow, with tab-model prompt for the confirmation install,
> this “Download box” disappears when the tab-model is closed (“x” button) or
> Install/Cancel buttons are selected.
> 
> In the current Nightly/Aurora, the “Download box” from about:addons does not
> disappear because of the new add-on install flow, which replaced the
> tab-model with a doorhanger.

Thanks Vasilica for the additional info. Does that mean this bug does not exist in Firefox40 and onwards?
Flags: needinfo?(vasilica.mihasca)
(In reply to Ritu Kothari (:ritu) from comment #6)
> Thanks Vasilica for the additional info. Does that mean this bug does not
> exist in Firefox40 and onwards?

This bug is reproducible in Firefox 40 and Firefox 41. The “Download box” appears in about:addons, when a tab is closed during the add-on download process. Only a browser restart makes the “Download box” to disappear.
Flags: needinfo?(vasilica.mihasca)
Flags: qe-verify+
This is too late for 40. wontfix!
This is clearly not a mainline scenario. It seems it is too late to fix this for FF41. Adding a tracking flag for 42 to ensure this gets attention.
No action for a while, not tracking as it seems we don't care enough about this issue (and we shipped two releases with this bug).
Encountered this issue also running other steps:

1.Launch Firefox with a clean profile.
2.Go to about:addons -> Extensions
3.Open a new tab and navigate to https://addons.mozilla.org
4.Install an add-on.
5.Return to Add-ons Manager opened tab. -> http://i.imgur.com/Attrwlg.jpg
Unfortunately this edge case isn't enough to warrant work on it. We hope to completely remove that download box, which I think is only available on the search page. That will be taken care of in bug 1263313. So I'm going to won't fix this in lieu of the search page coming up with a flow similar to disco pane.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.