Closed Bug 1171231 Opened 5 years ago Closed 2 years ago

test_setup_and_send_imap_email.py: assert self.device.is_online AssertionError

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bzumwalt, Unassigned)

Details

Test test_setup_and_send_imap_email.py is failing on latest mozilla-central: http://jenkins1.qa.scl3.mozilla.com/view/Mozilla%20Lab/job/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/273/

Issue is not reproducible manually. Was unable to reproduce on ad hoc run due to a different failure ("TimeoutException: TimeoutException: Timed out after 135.1 seconds") with our timeout parameter set to 10000.

Traceback (most recent call last):
  File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 277, in run
    self.setUp()
  File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/email/test_setup_and_send_imap_email.py", line 24, in setUp
    self.connect_to_local_area_network()
  File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 992, in connect_to_local_area_network
    assert self.device.is_online
AssertionError


Device firmware (base)	L1TC100118D0
Device firmware (date)	03 Jun 2015 08:38:58
Device firmware (incremental)	eng.cltbld.20150603.043848
Device firmware (release)	4.4.2
Device identifier	flame
Device memory	219772 kB
Device serial	e472d81c
Device uptime	0 days 0 hours 2 minutes 13 seconds
Gaia date	02 Jun 2015 19:56:25
Gaia revision	9b7ed13e0dee
Gecko build	20150603010205
Gecko revision	b0a507af2b4a
Gecko version	41.0a1
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
I'm seeing this as well on the imagecompare version of this test.  In my case, it either shows above error, or the email sent to the address is not received within the time limit.  Since I couldn't repro this locally, was suspecting an issue with devices in the lab.  Happens more often with the non-bitbar devices than the bitbar one.
At some point it should have been connected, because otherwise it would already bail out here, I think:
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/gaia_test.py#388
So what I meant to say is, that this also could be a problem with the wifi network in the lab and on bitbar.
I meant to say, this connect_to_local_area_network() failure would not be unique to this test.
Is this still an issue?
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.