Firefox consistently crashes every time I close it. (crash in mozilla::MediaCacheStream::Close())

RESOLVED DUPLICATE of bug 1191889

Status

()

--
critical
RESOLVED DUPLICATE of bug 1191889
4 years ago
4 years ago

People

(Reporter: gfbett, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

unspecified
All
Windows
crash
Points:
---

Firefox Tracking Flags

(firefox41- affected)

Details

(Whiteboard: [patch in bug 1191889], crash signature)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Open firefox with a few tabs, and close it some seconds later


Actual results:

Crash in mozilla::MediaCacheStream::Close()


Expected results:

Firefox should close without crashing
Reporter: Does the crash happen with a clean profile, no extensions?
Status: UNCONFIRMED → NEW
Crash Signature: [@ mozilla::MediaCacheStream::Close()]
Ever confirmed: true
Flags: needinfo?(gfbett)
(Reporter)

Comment 3

4 years ago
I've tried refreshing the profile, and disabling the extensions with the same result.  I'll try today creating a new profile
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
(Reporter)

Comment 4

4 years ago
I created a new profile, with the same result. After browsing a littlebit, it crashes (I was on gog.com and infobae.com)
Flags: needinfo?(gfbett)

Comment 5

4 years ago
I am getting this for the 4th time today. It even crashed while loading crash-stats page while all other tabs were crashed.

1,529 crashes the past 7 days from crash-stats and 717 just the past 3 days.

Updated

4 years ago
Severity: normal → critical
Component: Untriaged → Video/Audio
Keywords: crash
OS: Windows 8.1 → Windows
Product: Firefox → Core
Hardware: x86_64 → All
Version: 38 Branch → unspecified

Comment 6

4 years ago
I suspect a Windows update may be the cause here. I don't know which one as I postponing those on my laptop for 2-3 months. 
These are Windows 7 updates:
https://support.microsoft.com/en-us/kb/3045685
https://support.microsoft.com/en-us/kb/3045645
https://support.microsoft.com/en-us/kb/3056819
https://support.microsoft.com/en-us/kb/3037574
https://support.microsoft.com/en-us/kb/3048070
https://support.microsoft.com/en-us/kb/3058515
https://support.microsoft.com/en-us/kb/3023224
https://support.microsoft.com/en-us/kb/3042553
https://support.microsoft.com/en-us/kb/3054476
https://support.microsoft.com/en-us/kb/3020369
https://support.microsoft.com/en-us/kb/3063858
https://support.microsoft.com/en-us/kb/3035583
https://support.microsoft.com/en-us/kb/3057839
https://support.microsoft.com/en-us/kb/3045999
https://support.microsoft.com/en-us/kb/3046482
https://support.microsoft.com/en-us/kb/3046306
https://support.microsoft.com/en-us/kb/3023215
https://support.microsoft.com/en-us/kb/3054891
https://support.microsoft.com/en-us/kb/2965284
https://support.microsoft.com/en-us/kb/3032655
https://support.microsoft.com/en-us/kb/3059317
https://support.microsoft.com/en-us/kb/3035490
https://support.microsoft.com/en-us/kb/3046269
https://support.microsoft.com/en-us/kb/3013531
https://support.microsoft.com/en-us/kb/2990214
https://support.microsoft.com/en-us/kb/3020370
https://support.microsoft.com/en-us/kb/3046002
https://support.microsoft.com/en-us/kb/3037581
https://support.microsoft.com/en-us/kb/3045171
https://support.microsoft.com/en-us/kb/2952664
> https://support.microsoft.com/en-us/kb/3033890
https://support.microsoft.com/en-us/kb/3055642
https://support.microsoft.com/en-us/kb/3061518

I only found 3033890 interesting.

gfbett: What updates were installed around the dates you started crashing in windows 8?
Flags: needinfo?(gfbett)

Comment 7

4 years ago
Restored to the point to before the windows updates and I continue to crash.

(In reply to gfbett from comment #4)
> I created a new profile, with the same result. After browsing a littlebit,
> it crashes (I was on gog.com and infobae.com)

Verified too, but if I create a new windows user profile, then it doesn't crash.
The current profile on this machine is 4½ years old (cmd: systeminfo | find /i "install date").
I may create a windows user profile and start copying things over until I crash again.
(Reporter)

Comment 8

4 years ago
I don't have the update 3033890 since it doesn't apply for windows 8.1. 

I'm not sure when the crashes started, but I think that was around the time a firefox update was pushed (maybe a patch of firefox 37) Since I erased the profile, I don't know for sure that I have all the crashes recorded since the beginning. The earliest that I have (from around 50 crash reports) is from 2015-05-15 with a fresh install of firefox 38.0.1
Flags: needinfo?(gfbett)

Comment 9

4 years ago
https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=7&range_unit=days&date=2015-07-13&signature=mozilla%3A%3AMediaCacheStream%3A%3AClose%28%29&version=Firefox%3A42.0a1#tab-graph

Nightly started spiking with this crash: 13th of June.
Aurora started spiking with this crash: 30th June - 3th of July. (Firefox 41)

By estimates we'll see another spike once beta hits 10th of August
And then 21st of September spike in release channel.
Comment hidden (obsolete)
Comment hidden (obsolete)
This was mentioned as a Beta top crash in the channel meeting. Tracked.
status-firefox41: --- → affected
tracking-firefox41: --- → +
Blocks: 778617
Component: Audio/Video → Audio/Video: Playback
See Also: → bug 1191889
Depends on: 1191889
See Also: bug 1191889
Whiteboard: [patch in bug 1191889]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 1191889
Resolution: --- → DUPLICATE
Duplicate of bug: 1191889
Removing FF41 tracking as the original bug 1191889 is FF41+ and fixed.
tracking-firefox41: + → -
You need to log in before you can comment on or make changes to this bug.