Hebrew names sorted incorrectly in the contact list

RESOLVED DUPLICATE of bug 1028988

Status

RESOLVED DUPLICATE of bug 1028988
3 years ago
3 years ago

People

(Reporter: aleth, Unassigned)

Tracking

trunk

Details

(Reporter)

Description

3 years ago
Afik reports:

The nightly builds are strange. 
My friends in Hebrew going first, and then, my friends in english.... in the
regular version, there is not problem with it. 

Before the contacts in english, my friends in Hebrew listed like a,b,c, in
Hebrew is aleph, bet, gimmel.
Like this 
אלון פרץ 
בר יפרח 
גל בן גיגי 
And so on...

Comment 1

3 years ago
afik.sofer@gmail.com
(Reporter)

Comment 2

3 years ago
What locale (language) were you using for 1.5? The same as the nightly?

Comment 3

3 years ago
i use the program in English

Comment 4

3 years ago
and yes, the same as the nightly
(Reporter)

Comment 5

3 years ago
In nightlies,
"ב".localeCompare("c") == 1
"b".localeCompare("c") == -1
"ב".localeCompare("a") == 1
"b".localeCompare("a") == 1

In 1.5
"ב".localeCompare("c") == 2
"b".localeCompare("c") == -2
"ב".localeCompare("a") == 2
"b".localeCompare("a") == 2

From this, it looks like the result value has changed, but not in a way that should cause any change in the ordering.
I'm not sure exactly what the change was here.

If Hebrew used to be sorted after English:

apple
box
cat
...
אלון
בית
גמל

 but now it sorts before

אלון
בית
גמל
...
apple
box
cart

 -- then this sounds like the same issue as bug 1028988
(Reporter)

Comment 7

3 years ago
Since 1.5 was based on gecko 25, this seems to fit well.

As per comment 17 in the bug smontagu linked to (https://bugzilla.mozilla.org/show_bug.cgi?id=1028988#c17), this is not a bug, merely changed behaviour (and arguably the new behaviour is more standard).
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028988
You need to log in before you can comment on or make changes to this bug.