"Remember this decision" needs granularity (e.g. "for this session")

RESOLVED DUPLICATE of bug 53354

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 53354
17 years ago
3 years ago

People

(Reporter: mozbugs2, Assigned: morse)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    

"Remember this decision" for cookies and images is an always/never option, but
in many cases it's not clear that it should be.  Ideally it should be possible
to specify options other than the implicit "forever" for how long the decision
should be remembered.

Good options would probably be:
 * For this page (multi-image pages)
 * Until Mozilla exits/For this session
 * For 1 day
 * Permanently

These could probably be presented as a dropdown next to the text, and could have
a default set from the preferences panels where prompting for cookies and images
is enabled.  This could also be an "advanced" option from the same panels, with
the dropdown not normally visible.


Reproducible: Always
Steps to Reproduce:
Turn on prompting for cookies or images; load a site using cookies or images.

Comment 1

17 years ago
confirming. 

a dropdown with a defaul specified in the prefs would be a very good way to
implement this feature... however, this would require some back-end work to
allow us to specify different lengths of time to "remember"
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Steve Morse's department.
Assignee: sgehani → morse
Component: Preferences → Cookies
QA Contact: sairuh → tever
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

16 years ago
i definitely want the ability to accept session cookies from certains sites,
while rejecting longer-term cookies from the same sites.  have to admit that
IE's ability to look at cookie details before you accept it is nice too.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 53354 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.