Closed Bug 117156 Opened 18 years ago Closed 12 years ago

warning code in bidi code

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 126484

People

(Reporter: ftang, Assigned: smontagu)

References

(Blocks 1 open bug)

Details

warnning is our friend. we should check careful of the following warnning. It
could be a clue for us to fix some bugs:

[ftang@ftang src]$ gmake
Updating dependencies file, .deps/.all.pp
gmake export
gmake[1]: Entering directory `/builds/opt/mozilla/intl/unicharutil/src'
gmake[1]: Nothing to be done for `export'.
gmake[1]: Leaving directory `/builds/opt/mozilla/intl/unicharutil/src'
gmake libs
gmake[1]: Entering directory `/builds/opt/mozilla/intl/unicharutil/src'
nsBidiUtilsImp.cpp
c++ -o nsBidiUtilsImp.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" -DOJI  -I../
../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/
uconv -I../../../dist/include/necko -I../../../dist/include/unicharutil -I../../
../dist/include -I/builds/opt/mozilla/dist/include/nspr      -I/usr/X11R6/includ
e   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wp
ointer-arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth -Wno-
ctor-dtor-privacy -pedantic -Wno-long-long -fshort-wchar -pthread -pipe  -DNDEBU
G -DTRIMMED -O  -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../config-d
efs.h -Wp,-MD,.deps/nsBidiUtilsImp.pp nsBidiUtilsImp.cpp
nsBidiUtilsImp.cpp: In method `nsresult nsBidiUtilsImp::GetCharType
(short unsigned int, nsCharType *)':
nsBidiUtilsImp.cpp:323: warning: comparison between signed and unsigned
integer expressions
nsBidiUtilsImp.cpp:329: warning: comparison between signed and unsigned
integer expressions
nsBidiUtilsImp.cpp: In method `nsresult nsBidiUtilsImp::ArabicShaping
(const PRUnichar *, unsigned int, PRUnichar *, PRUint32 *)':
nsBidiUtilsImp.cpp:357: warning: `PRInt8 leftNoTrJ' might be used
uninitialized in this function
nsBidiUtilsImp.cpp: In method `nsresult nsBidiUtilsImp::Conv_FE_06
(nsString, nsString &)':
nsBidiUtilsImp.cpp:485: warning: statement with no effect
nsBidiUtilsImp.cpp: In method `nsresult
nsBidiUtilsImp::Conv_FE_06_WithReverse (nsString, nsString &)':
nsBidiUtilsImp.cpp:518: warning: `PRUint32 beginArabic' might be used
uninitialized in this function
nsBidiUtilsImp.cpp: In method `nsresult
nsBidiUtilsImp::Conv_06_FE_WithReverse (nsString, nsString &, unsigned
int)':
nsBidiUtilsImp.cpp:575: warning: `PRUint32 beginArabic' might be used
uninitialized in this function
nsBidiUtilsImp.cpp:607: warning: `PRUint32 beginNumeral' might be used
uninitialized in this function
nsBidiImp.cpp
c++ -o nsBidiImp.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" -DOJI  -I../../..
/dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/uconv
 -I../../../dist/include/necko -I../../../dist/include/unicharutil -I../../../di
st/include -I/builds/opt/mozilla/dist/include/nspr      -I/usr/X11R6/include   -
fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointe
r-arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-
dtor-privacy -pedantic -Wno-long-long -fshort-wchar -pthread -pipe  -DNDEBUG -DT
RIMMED -O  -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../config-defs.h
 -Wp,-MD,.deps/nsBidiImp.pp nsBidiImp.cpp
nsBidiImp.cpp: In method `void nsBidi::ResolveImplicitLevels (int, int,
unsigned char, unsigned char)':
nsBidiImp.cpp:858: warning: `DirProp beforeNeutral' might be used
uninitialized in this function
nsBidiImp.cpp: In method `void nsBidi::ReorderLine (unsigned char,
unsigned char)':
nsBidiImp.cpp:1718: warning: unused variable `PRInt32 trailingWSStart'
rm -f libunicharutil.so
c++ -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-
arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dt
or-privacy -pedantic -Wno-long-long -fshort-wchar -pthread -pipe  -DNDEBUG -DTRI
MMED -O -shared -Wl,-h -Wl,libunicharutil.so -o libunicharutil.so  nsCaseConvers
ionImp2.o nsUcharUtilModule.o nsCategoryImp.o nsHankakuToZenkaku.o nsEntityConve
rter.o nsSaveAsCharset.o nsBidiUtilsImp.o nsBidiImp.o       -L../../../dist/bin
-lxpcom -L../../../dist/bin -L/builds/opt/mozilla/dist/lib -lplds4 -lplc4 -lnspr
4 -lpthread -ldl -lc   -Wl,--version-script -Wl,../../../build/unix/gnu-ld-scrip
ts/components-version-script -ldl -lm  -lc
chmod +x libunicharutil.so
../../../config/nsinstall -R -m 755 libunicharutil.so ../../../dist/lib/componen
ts
reassign to smontagu.
This is what I got when I comple intl/unicharutil/src on Linux.
Don't fix the warnning blindly. Fix it carefully, it may be a clue.
Assignee: ftang → smontagu
Summary: warnning code in bidi code → warning code in bidi code
Status: NEW → ASSIGNED
Blocks: buildwarning
This was all taken care of a long time ago in bug 126484.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 126484
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.