Closed Bug 1171626 Opened 7 years ago Closed 7 years ago

Tapping item in Reading List takes you to article or causes crash

Categories

(Firefox for iOS :: Reading List, defect)

All
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: tecgirl, Assigned: st3fan)

Details

(Keywords: crash)

Attachments

(1 file)

Tapping the blue indication dot in Reading List should toggle the Read/Unread state.

Instead, it will either navigate to the article or cause a crash.
ReadabilityBrowserHelper.init?, browser.webView! -- but .webView is nil.

This is running on the main thread, triggered via ReadabilityOperation.main:50.

Should be pretty easy to solve via inspection.
Assignee: nobody → sarentz
Status: NEW → ASSIGNED
Keywords: crash
Hardware: Other → All
Summary: Tapping on indication dot in Reading List takes you to article or causes crash → Tapping item in Reading List takes you to article or causes crash
The blue dot is just an indicator. It is not a button.

To toggle the read/unread state, swipe the cell to the right.

This is a major regression and can be summarized as 'Opening an item from the reading list causes a crash'

This must be because of some other unrelated changes. I'll investigate.
This is because of the lazy loading of the WKWebview that was introduced recently.
This patch fixes a regression that was introduced after the lazy loading of the `WKWebView` was implemented. The `ReadabiltyOperation` requires the `Browser.webView` to be present so this patch simply calls `createWebview()` to ensure that.
Attachment #8629193 - Flags: review?(sleroux)
Comment on attachment 8629193 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/669

Looks good to me!
Attachment #8629193 - Flags: review?(sleroux) → review+
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Robin, this crash is fixed. But see comment #2 about the blue dot not being a button. Please file a bug if that needs to change.
Flags: needinfo?(randersen)
Flags: needinfo?(randersen)
You need to log in before you can comment on or make changes to this bug.