downloadable fonts (including Bugzilla) don't antialias on Linux

RESOLVED DUPLICATE of bug 1180415

Status

()

--
major
RESOLVED DUPLICATE of bug 1180415
4 years ago
4 years ago

People

(Reporter: shawnlandden, Unassigned)

Tracking

({regression})

41 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150603030208

Steps to reproduce:

Go to site with downloadable font (such as this bugzilla)


Actual results:

Fonts look OK, and then when stylesheet is downloaded re-render without antialiasing.

http://snag.gy/3NiK8.jpg


Expected results:

Beautiful fonts

Updated

4 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
[Tracking Requested - why for this release]: Regression

Probably a fallout of bug #1056479

@ scientes - Please set "gfx.font_rendering.fontconfig.fontlist.enabled" to "false" in about:config to see if it fix the issue.
Blocks: 1056479
Severity: normal → major
status-firefox40: --- → unaffected
status-firefox41: --- → affected
tracking-firefox41: --- → ?
Flags: needinfo?(shawnlandden)
Keywords: regression
(Reporter)

Comment 2

4 years ago
That doesn't work. I am also having problems with HTML5 videos sometimes (but not always) not displaying. Sometimes they also show only the first frame the whole time. The audio still plays.
Flags: needinfo?(shawnlandden)
(Reporter)

Comment 4

4 years ago
My graphics is Intel i965
Can you get an inbound build regression window?
Flags: needinfo?(shawnlandden)
(Reporter)

Comment 6

4 years ago
That part of mozregressions-gui doesn't seem to be working. Do I need https://github.com/mozilla/gecko-dev checked out?
Flags: needinfo?(shawnlandden)
(Reporter)

Comment 7

4 years ago
I don't have enough RAM to build firefox.
You shouldn't need to build firefox to get these resuts. Can you try using the non-gui version of mozregression?
Flags: needinfo?(shawnlandden)
(Reporter)

Comment 9

4 years ago
I managed to narrow it down a little more, but mozregressions keeps crashing:

$ mozregression --good-rev=b3d61b6150fd --bad-rev=59d11e593eca --app=firefox  --bits=64
 0:06.61 LOG: MainThread Bisector INFO Getting inbound builds between b3d61b6150fd and 59d11e593eca
 0:40.97 LOG: MainThread Bisector INFO Downloading build from: http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux64/1432312367/firefox-41.0a1.en-US.linux-x86_64.tar.bz2
===== Downloaded 100% =====
Retrieving valid builds from (u'http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux64/1432914639/', 1432914639) generated an exception: []
 4:36.65 LOG: Dummy-123 Bisector INFO Last good revision: b3d61b6150fd
 4:36.65 LOG: Dummy-123 Bisector INFO First bad revision: 59d11e593eca
 4:36.65 LOG: Dummy-123 Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b3d61b6150fd&tochange=59d11e593eca

 4:36.65 LOG: Dummy-123 Bisector INFO To resume, run:
 4:36.65 LOG: Dummy-123 Bisector INFO mozregression --good-rev=b3d61b6150fd --bad-rev=59d11e593eca --app=firefox  --bits=64
Flags: needinfo?(shawnlandden)
Can you report a mozregression bug?
This regression window is still not really narrow enough to be helpful so it would be good if we could fix the mozregression bug and get it tighter.
(In reply to scientes from comment #2)
> That doesn't work. I am also having problems with HTML5 videos sometimes
> (but not always) not displaying. Sometimes they also show only the first
> frame the whole time. The audio still plays.

Sorry, but just to confirm, if you set "gfx.font_rendering.fontconfig.fontlist.enabled" to "false" in about:config and *restart* you still see the same problem? If so, then this is something other than bug 1056479.

It would help if you could screenshot the same page with the above pref set to false and then to true again. You'll need to restart each time.
Flags: needinfo?(shawnlandden)

Comment 13

4 years ago
Tracking because regression and 41 is affected.
tracking-firefox41: ? → +
(Reporter)

Comment 14

4 years ago
Ahh, you should have specified I needed to restart. If I restart setting gfx.font_rendering.fontconfig.fontlist.enabled false works!
Flags: needinfo?(shawnlandden)
(In reply to scientes from comment #14)
> Ahh, you should have specified I needed to restart. If I restart setting
> gfx.font_rendering.fontconfig.fontlist.enabled false works!

Well, that makes this a regression of bug 1056479. Could you attach screenshots of the testpage you're using with and without that pref set? Remember to restart... ;)

Are you using any sort of custom fontconfig settings?

Thanks!!
Flags: needinfo?(shawnlandden)
(Reporter)

Comment 16

4 years ago
Here is the good: http://snag.gy/dK1JG.jpg

The bad is above. The bad always looks like that.

if I type "fontconfig" into about:config only that pref shows up. In Debian GNOME my settings are fairly standard.
Flags: needinfo?(shawnlandden)
Whiteboard: [gfx-noted]
Created attachment 8628680 [details]
screenshot, fontconfig platform fontlist vs. pangofontgroup

Running Ubuntu 14.04, I'm not seeing this.

Left side is the new, trunk code, right side is the old gfxPangoFontGroup code. I don't see the dramatic differences you're seeing.

Shawn, are you seeing this for *all* downloadable fonts? Or just some fonts on some pages? Which version/flavor of Debian are you using? Also, could you copy and attach the contents of about:support? Sorry for the trouble.
Flags: needinfo?(shawnlandden)
Guessing that this may be the same problem as bug 1180415. Shawn, could you confirm whether this problem still occurs in the latest nightly?

Updated

4 years ago
See Also: → bug 1180415
(Reporter)

Comment 19

4 years ago
This appears to be fixed. I will reopen if this regresses.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(shawnlandden)
Resolution: --- → DUPLICATE
Duplicate of bug: 1180415
status-firefox40: unaffected → ---
status-firefox41: affected → ---
tracking-firefox41: + → ---
You need to log in before you can comment on or make changes to this bug.