Closed Bug 1171768 Opened 5 years ago Closed 5 years ago

[Settings] Enabling USB Storage (UMS) and connecting it to PC does not list any of phone's storages on PC

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: pcheng, Unassigned)

References

Details

(Keywords: regression, smoketest, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Attached file logcat of issue
On the Flame, user cannot connect and explore storage devices after enabling USB storage.

STR:
1) Go to Settings app and toggle on USB Storage (tap OK if a prompt appears)
2) Connect an USB cable from device to computer

Expected: Storage on the phone are listed as drives on computer

Actual: Nothing happens

Repro rate: 9 out of 10.

Attaching a logcat.

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150604010200
Gaia: 9e10483c5808f94f4a0a9f6afe30aae2c5b42b4c
Gecko: 98820360ab66
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
This appears to be a recent regression. Does not happen on 2.2 and does not happen on yesterday's 3.0 nightly.

Device: Flame 2.2
BuildID: 20150604002503
Gaia: b96e657ce2822df5da5da1a8ba91c38ad3281bc9
Gecko: 273f8ee45c88
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
BuildID: 20150603010205
Gaia: 9b7ed13e0dee26b9f16ae5fbc076fa8bd588b256
Gecko: b0a507af2b4a
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
[Blocking Requested - why for this release]:

Regression of a major function so nominating this 3.0?
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: jmercado
I'm not going to be able to get this one finished in b2g-inbound by the end of the night so here is the central window.  I will finish this asap tomorrow.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150603083842
Gaia: 477b5672811ed970a7476fe6f67dba546a302dce
Gecko: 83367fdf47b1
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150603125141
Gaia: 45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gecko: e5ee2c56963c
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 477b5672811ed970a7476fe6f67dba546a302dce
Gecko: e5ee2c56963c

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gecko: 83367fdf47b1

Gecko Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=83367fdf47b1&tochange=e5ee2c56963c
Flags: needinfo?(ktucker)
Upgrading to smoketest blocker, as it fails this case: https://moztrap.mozilla.org/manage/case/6072/
Keywords: smoketest
The changes for Bug 1166320 seem to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150603095742
Gaia: a99fd34784286efc935e07ddd55161d43950f673
Gecko: 2fb400ee696e
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150603104542
Gaia: a99fd34784286efc935e07ddd55161d43950f673
Gecko: 371c3a42b25c
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: a99fd34784286efc935e07ddd55161d43950f673
Gecko: 371c3a42b25c

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: a99fd34784286efc935e07ddd55161d43950f673
Gecko: 2fb400ee696e

Gecko Pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=2fb400ee696e&tochange=371c3a42b25c
QA Whiteboard: [QAnalyst-Triage?]
Andrew, can you take a look at this please? We think the landing for bug 1166320 might be the cause here. We will need a backout since this is a smoke test blocier.
Blocks: 1166320
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(aosmond)
Assignee: nobody → aosmond
Backed out.
Flags: needinfo?(aosmond)
FYI I reverted this locally and I have UMS working again on master \o/. So I'm confident it will be okay for QA :)
This issue is verified fixed with the provided Aries build.

Actual Results: The user can access the device storage when USB Mass Storage is enabled.

Environmental Variables:
Device: Aries 3.0
BuildID: 20150605202112
Gaia: 55858863f320efc73c0bfd9b3eef905e49998e39
Gecko: 163b199605d9
Gonk: 3af1ede0d0956cfbf9c549df7cd9a6807a9efdf2
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Marking fixed by backout.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue is verified Fixed on the latest Flame build.
USB Storage on the phone are listed as drives on computer

Environmental Variables:
Device: Flame 3.0
Build ID: 20150608010204
Gaia: 1d62b32408567f9f7cf1c71c1e5a0c6593be757b
Gecko: 7d4ab4a9febd
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
Moving the bug to the component where the regression came from.
Assignee: aosmond → nobody
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Settings → DOM: Device Interfaces
Product: Firefox OS → Core
You need to log in before you can comment on or make changes to this bug.