Closed Bug 1171894 Opened 5 years ago Closed 3 years ago

Reader View icon is shown for several apple.com trailers

Categories

(Toolkit :: Reader Mode, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox41 --- affected

People

(Reporter: vasilica.mihasca, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Reproducible on: Firefox 38.0.5, Firefox 39 Beta 3, Firefox 40.0a2, Firefox 41.0a1

STR
1.Launch Firefox with clean profile
2.Navigate to http://trailers.apple.com/trailers/magnolia/nowitzkitheperfectshot/
3.Play the video
4.Click on “Reader view” button from location bar

ER
Reader view button is not displayed while the videos are played.

AR
“Failed to load article from page” message is displayed in reader view mode and the following error is thrown in browser console: ”Error in ReaderWorker: TypeError: this._doc.documentElement is undefined ReaderMode.jsm:357:0”


Additional notes:
 - This issue is reproducible on Firefox 40.0a2 (2015-06-04), Firefox 41.0a1 (2015-06-04), Firefox 39 Beta 3 ( 20150604162752), Firefox 38.0.5 (20150525141253) under Mac OS X 10.8.5
 - This issue also reproduces for the following trailers:
http://trailers.apple.com/trailers/independent/theaputrilogypatherpanchaliaparajitoapursansar/
http://trailers.apple.com/trailers/magnolia/apigeonsatonabranch/
http://trailers.apple.com/trailers/wb/pointbreak/
http://trailers.apple.com/trailers/independent/cartelland/
http://trailers.apple.com/trailers/independent/freedom/
Gijs, could you please have a look at this? I'm aware that it's a bit of an edge case, but I'm mostly concerned about the error thrown in the Browser Console.
Flags: needinfo?(gijskruitbosch+bugs)
It's because JSDOMParser fails to produce a DOM out of this HTML. I haven't yet investigated why. Errors:

JSDOMParser error: expected '</object>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</div>'
JSDOMParser error: expected '</body>'
JSDOMParser error: expected '</html>'

So it looks like the object end tag is missing.
It's failing because the <embed> tag has a closing tag, which goes against the HTML spec, and because JSDOMParser is pretty inflexible in this respect.

I don't think this is worth fixing unless there are very many pages with this issue.
Flags: needinfo?(gijskruitbosch+bugs)
WFM, I no longer see the reader mode button, and I think github https://github.com/mozilla/readability/pull/252 fixed the <embed> issue anyway.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.