[Aries] Time, date and unlock slider are sometimes loaded half a second after the rest of the screen

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Lockscreen
P3
normal
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

(Blocks: 1 bug, {foxfood, perf})

unspecified
ARM
Gonk (Firefox OS)
foxfood, perf

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [spark])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8615945 [details]
Turn on the screen - Flame/Aries comparison - video

[Blocking Requested - why for this release]: Regression from the Flame.


STR (while dogfooding)
1. Unlock the screen

STR (to reproduce faster)
1. Lock the screen
2. Right after, press the lock button to turn of the screen
3. Repeat the operation a couple of times, if needed.

Result
Unlike the current master on the Flame, sometimes the lockscreen text is not immediately displayed. If you light up the device just to take a look at the time, you might feel the device is slow to respond, especially on a high-end device like the Z3C.

See the attached video, which compares between the Flame (on the current master) and Aries.


Build info
Build ID               20150604030544
Gaia Revision          0b00f058eeee79a05345b793eb5efa19f166ab3f
Gaia Date              2015-06-03 21:20:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/98820360ab66
Gecko Version          41.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150604.025108
Firmware Date          Thu Jun  4 02:51:16 UTC 2015
Bootloader             s1
(Reporter)

Comment 1

3 years ago
Side note: There was no background app running on both devices.
(Reporter)

Updated

3 years ago
Keywords: foxfood
(Reporter)

Updated

3 years ago
Keywords: dogfood
Whiteboard: [spark][systemsfe] → [spark]
Long shot, but might be confirmed also on Flame, is that what seems to trigger the slowdown is somehow linked with placing and/or receiving phone calls. After several days using a device where I made sure not to place calls and received very very few (one in 4 days), the slowdown was clearly not there.

Comment 3

3 years ago
Same on Flame device, currently I have it on:

TCT Flame (got from Foxtrot Programme)
B2G version: 2.5.0.0-prerelease master
Platform version: 42.0a1
Build Identifier: 20150716010206
Firmware: v18D_nightly_v3
Git commit info: 2015-07-16 00:34:27 981c61cd

The delay is not the same every time, sometimes it is 1 sec, sometimes is so long that screen only blink and turns off. Usually is is about 2 secs.
blocking-b2g: 2.5? → 2.5+
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> Long shot, but might be confirmed also on Flame, is that what seems to
> trigger the slowdown is somehow linked with placing and/or receiving phone
> calls. After several days using a device where I made sure not to place
> calls and received very very few (one in 4 days), the slowdown was clearly
> not there.

So I did track some of the issues in bug 1189004. Fixed three of them, dogfooding the device and I clearly do not reproduce anymore the slowdown that was tracked here.

Johan, mac, it would be great that you can confirm this!
Flags: needinfo?(zrzut01)
Flags: needinfo?(jlorenzo)
Lets get a new logcat if this happens again. We have additional logging patches in place.
(Reporter)

Comment 6

3 years ago
I updated my device to the latest master. Let's see if I get anything.
Flags: needinfo?(jlorenzo)
Hey Johan, 

Just a reminder. Please post the logs/details required. 

Thanks
Flags: needinfo?(jlorenzo)
(Reporter)

Comment 8

3 years ago
Created attachment 8659328 [details]
logcat

In this logcat, I turned on the screen 3 times. The first 2 times showed the long response time. This was performed against:

Build ID               20150817141354
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a6eeb28458fd2652e12e57334f046b7776d75bb4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150619.224059
Firmware Date          Fri Jun 19 22:41:08 UTC 2015
Bootloader             s1
Flags: needinfo?(jlorenzo)
I will take a look. But now the STR looks a bit confused, and I suspect that it happens intermittently according to the comments above.

Another issue is that the logcat shows a issue about too verbosed logging in Gaia about one month ago, which was fixed after 8/16, the date in your comment. I may get a build with latest Gaia to see if this still occurs without the logging issue.

Tim: do you think we need a more formal regression window or other information to identify it as a 2.5+? I have some concerns about to mark it as a blocker even without stable STR and other info we usually can see in a blocker bug.
Flags: needinfo?(timdream)
Please ask QA whether or not the STR is stable enough to get an regression window, not me. Normally when the questions is asked the answer is probably "no" since you have doubt yourself too. :)
Flags: needinfo?(timdream)
According to Comment 10, ask QA's opinion and to see if we can get a more stable STR.
Keywords: qawanted
QA Contact: sleedavid
Not able to Repro. per following build(s) on Aries and Flame: 

Environmental Variables:
Device: Aries 2.5
BuildID: 20150918122511
Gaia: 4f22dfecdc046fe5223ee858dd06c11b75884740
Gecko: 37c7812ce0e6d10c7e7182f12e752832835e1d67
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0


Environmental Variables:
Device: Flame 2.5
BuildID: 20150917030226
Gaia: db6664f0e07e9966283d30cfc7006151fe7103ff
Gecko: e7d613b3bcfe1e865378bfac37de64560d1234ec
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

used STR: 
STR (while dogfooding)
1. Unlock the screen

STR (to reproduce faster)
1. Lock the screen
2. Right after, press the lock button to turn of the screen
3. Repeat the operation a couple of times, if needed.
Flags: needinfo?(jmercado)
QA Contact: sleedavid
Flags: needinfo?(jmercado)
We need more information from reporter. Is this bug about:

1) when screen is off, pressing power button - screen wakes up displaying one thing after another, that the lockscreen doesn't display everything as a whole.

or

2) when screen is off, pressing power button - screen doesn't wake up immediately, but lockscreen displays everything as a whole.

or

3) a combination of (1)+(2)?

I was only able to repro (2), not (1) nor (3).
(2) happens on Aries, Flame 2.5 and Flame 2.2, which contradicts with comment 0. Note that I tested this withOUT apps running in background as comment suggests.

----

According to reporter this issue is Aries only and does not happen on Flame. Judging by the date of this bug (6/5) I think it is sufficient to say it's not a regression within Aries.

Conclusion: Regression window is not possible on any of the scenarios.

Device: Aries 2.5
BuildID: 20150918122511
Gaia: 4f22dfecdc046fe5223ee858dd06c11b75884740
Gecko: 37c7812ce0e6d10c7e7182f12e752832835e1d67
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: unaffected → ---
Flags: needinfo?(jmercado)
Keywords: qawanted, regression
Johan can you please give your thoughts on comment 13?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(jlorenzo)
(Reporter)

Comment 15

2 years ago
This bug was about (1):
> when screen is off, pressing power button - screen wakes up displaying one thing after another, that the lockscreen doesn't display everything as a whole.

I agree with Pi-Wei, no regression window is possible. This was identified on the one of the earliest Aries build.
Flags: needinfo?(jlorenzo)
(Reporter)

Comment 16

2 years ago
Regarding the STR, there was an improvement that made it harder to use the clearly identified 3 steps. However, the problem was still here while dogfooding on the build I had in comment 13. I'll update my dogfood device to get a new logcat.
I recommend re-block only when there is more detail here.
blocking-b2g: 2.5+ → 2.5?

Comment 18

2 years ago
I can confirm that the problem still exists. I use my Flame with Master for everyday. The delay shows not every time but about 6 out of 10 in average.
Mac, Can you please provide more details on STR?

Johan - Any luck with the new logcat?
(Reporter)

Updated

2 years ago
Flags: needinfo?(jlorenzo)
[Tracking Requested - why for this release]:As there are no logs to investigate, removing for 2.5 and adding as part of backlog.
blocking-b2g: 2.5? → ---
tracking-b2g: --- → backlog
(Reporter)

Comment 21

2 years ago
I don't know if my eyes got used to it, but I don't notice the issue anymore on my dogfood device.

In details:
When I don't touch my phone for a couple of hours, I do see the time appearing a split second after the wallpaper. Nevertheless, when I turn the screen off and on right away (comment 0), I don't get it anymore

So I don't have any logcat to provide. Mac, do you still manage to reproduce?
Flags: needinfo?(jlorenzo)

Updated

2 years ago
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(zrzut01)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.