More useful user onboarding/tours

RESOLVED DUPLICATE of bug 1203546

Status

()

Firefox for iOS
General
RESOLVED DUPLICATE of bug 1203546
2 years ago
2 years ago

People

(Reporter: bnicholson, Assigned: darrin)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios1.1+)

Details

(Reporter)

Description

2 years ago
With the recent UR feedback, most people agreed that the startup screen was lacking and could include more. Trying to cram too much into the intro screen will have diminishing (and even negative) returns, though, so we should investigate other ways to guide the user as they explore the app.

Some recurring topics worth consideration:
* Finding and setting search engines
* Explaining the home panels (especially how Top Sites works, and Top Sites vs. History)
* Finding and using the Reading List
tracking-fennec: ? → +
tracking-fxios: ? → +
(Assignee)

Updated

2 years ago
Assignee: nobody → dhenein
tracking-fennec: + → ---
v1 scope?
tracking-fxios: + → ?
tracking-fxios: ? → 2.0+
More, on the theme of affordances and actionable offers:

---
1. The only hint that the user should swipe to advance the Tour is the three tiny gray dots at the bottom of the page. My wife did not know that the dots are a common (but subtle) iOS UI pattern. So the first thing she did was tap the "Start Browsing" button, inadvertently skipping the rest of the Tour.

2. The Tour text does not describe *how* to access any of the features. "Browse multiple Web pages". OK. "Personalize your Firefox". Sounds good. But *how*? The Tour text does not refer to the UI controls in the graphics.

3. The Tour graphics are so minimalist that my wife did not realize they are an abstract representation of the Fennec UI that *she has not actually seen yet*. The graphics would benefit from animated arrows or highlights directing the user to the tab or settings button (and that are referenced from the Tour text).

4. On the finalize page of the Tour, my wife did not realize that "Sign in to Firefox" was optional. Not wanting to "create yet another account" when Safari doesn't need one, she almost gave up here. The description "Connect Firefox everywhere you use it" doesn't actually mean anything if I didn't already know what Firefox Sync is. Plus the Tour text does not actually use the term "Firefox Sync" or describe the benefits of Sync. My wife is not a Sync user because she uses Firefox on just one desktop computer and does not use Android, so she has had no need to know what Sync is.
---
tracking-fxios: 2.0+ → 1.1+
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203546
You need to log in before you can comment on or make changes to this bug.