hg pull on 20150605 fails to compile, error: ‘DetailedPromise’ was not declared in this scope

RESOLVED DUPLICATE of bug 1171786

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1171786
2 years ago
2 years ago

People

(Reporter: stan, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8616318 [details]
This is the .mozconfig that I am running.  Not standard!

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150602154008

Steps to reproduce:

1.  hg pull -u
2. ./mach build


Actual results:

0:15.12 UnifiedBindings13.o
 0:15.54 libtoolkit_components_ctypes.a.desc
 0:15.57 Omnijar.o
 0:20.19 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dom/bindings/MediaKeySessionBinding.cpp:10:0,
 0:20.19                  from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dom/bindings/UnifiedBindings10.cpp:26:
 0:20.19 ../../dist/include/mozilla/dom/MediaKeySession.h:100:20: error: ‘DetailedPromise’ was not declared in this scope
 0:20.19    already_AddRefed<DetailedPromise> MakePromise(ErrorResult& aRv);
 0:20.20                     ^
 0:20.20 ../../dist/include/mozilla/dom/MediaKeySession.h:100:35: error: template argument 1 is invalid
 0:20.20    already_AddRefed<DetailedPromise> MakePromise(ErrorResult& aRv);
 0:20.20                                    ^
 0:20.20 ../../dist/include/mozilla/dom/MediaKeySession.h:102:12: error: ‘DetailedPromise’ was not declared in this scope
 0:20.20    nsRefPtr<DetailedPromise> mClosed;
 0:20.20             ^
 0:20.20 ../../dist/include/mozilla/dom/MediaKeySession.h:102:27: error: template argument 1 is invalid
 0:20.20    nsRefPtr<DetailedPromise> mClosed;
 0:20.20                            ^
 0:20.20 
 0:20.20 In the directory  /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dom/bindings
 0:20.20 The following command failed to execute properly:
 0:20.20 /bin/ccache c++ -o UnifiedBindings10.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /mnt/to_archive/accum/src/mozilla-central/config/gcc_hidden.h -DOS_POSIX=1 -DOS_LINUX=1 -DHAVE_SIDEBAR -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/mnt/to_archive/accum/src/mozilla-central/dom/bindings -I. -I../../dist/include/mozilla/dom -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/ipc/ipdl/_ipdlheaders -I/mnt/to_archive/accum/src/mozilla-central/dom/base -I/mnt/to_archive/accum/src/mozilla-central/dom/battery -I/mnt/to_archive/accum/src/mozilla-central/dom/bluetooth -I/mnt/to_archive/accum/src/mozilla-central/dom/camera -I/mnt/to_archive/accum/src/mozilla-central/dom/canvas -I/mnt/to_archive/accum/src/mozilla-central/dom/geolocation -I/mnt/to_archive/accum/src/mozilla-central/dom/html -I/mnt/to_archive/accum/src/mozilla-central/dom/indexedDB -I/mnt/to_archive/accum/src/mozilla-central/dom/media/webaudio -I/mnt/to_archive/accum/src/mozilla-central/dom/media/webspeech/recognition -I/mnt/to_archive/accum/src/mozilla-central/dom/svg -I/mnt/to_archive/accum/src/mozilla-central/dom/workers -I/mnt/to_archive/accum/src/mozilla-central/dom/xbl -I/mnt/to_archive/accum/src/mozilla-central/dom/xml -I/mnt/to_archive/accum/src/mozilla-central/dom/xslt/base -I/mnt/to_archive/accum/src/mozilla-central/dom/xslt/xpath -I/mnt/to_archive/accum/src/mozilla-central/dom/xul -I/mnt/to_archive/accum/src/mozilla-central/js/xpconnect/src -I/mnt/to_archive/accum/src/mozilla-central/js/xpconnect/wrappers -I/mnt/to_archive/accum/src/mozilla-central/layout/style -I/mnt/to_archive/accum/src/mozilla-central/layout/xul/tree -I/mnt/to_archive/accum/src/mozilla-central/media/mtransport -I/mnt/to_archive/accum/src/mozilla-central/media/webrtc/ -I/mnt/to_archive/accum/src/mozilla-central/media/webrtc/signaling/src/common/time_profiling -I/mnt/to_archive/accum/src/mozilla-central/media/webrtc/signaling/src/peerconnection -I/mnt/to_archive/accum/src/mozilla-central/ipc/chromium/src -I/mnt/to_archive/accum/src/mozilla-central/ipc/glue -I/mnt/to_archive/accum/src/mozilla-central/dom/bluetooth/bluetooth1 -I../../dist/include -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dist/include/nspr -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MP -MF .deps/UnifiedBindings10.o.pp -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -Wno-uninitialized -DNDEBUG -DTRIMMED -g -O3 -fomit-frame-pointer /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dom/bindings/UnifiedBindings10.cpp
 0:20.20 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:946: recipe for target 'UnifiedBindings10.o' failed
 0:20.20 gmake[5]: *** [UnifiedBindings10.o] Error 1
 0:20.20 gmake[5]: *** Waiting for unfinished jobs....

1:19.51 /mnt/to_archive/accum/src/mozilla-central/config/recurse.mk:71: recipe for target 'dom/bindings/target' failed
 1:19.51 gmake[4]: *** [dom/bindings/target] Error 2
 1:19.51 gmake[4]: *** Waiting for unfinished jobs....

1:42.32 libdom_quota.a.desc
 1:44.07 libxpcom_build.a.desc
 1:44.09 /mnt/to_archive/accum/src/mozilla-central/config/recurse.mk:32: recipe for target 'compile' failed
 1:44.09 gmake[3]: *** [compile] Error 2
 1:44.09 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:538: recipe for target 'default' failed
 1:44.09 gmake[2]: *** [default] Error 2
 1:44.09 /mnt/to_archive/accum/src/mozilla-central/client.mk:400: recipe for target 'realbuild' failed
 1:44.09 gmake[1]: *** [realbuild] Error 2
 1:44.09 client.mk:171: recipe for target 'build' failed
 1:44.09 gmake: *** [build] Error 2
 1:44.13 178 compiler warnings present.


Expected results:

Successful compile.  I'm currently running a successful compile of nightly that used a pull from last Friday, 20150529.  So, even though I run a non-standard .mozconfig, it usually works just fine.

Updated

2 years ago
Component: Untriaged → DOM
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171786
You need to log in before you can comment on or make changes to this bug.