If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash @ libc-2.11.2.so@0x10d356 | Firefox receives "SIGPIPE, Broken pipe", when browsing "mail.google.com"

RESOLVED DUPLICATE of bug 935458

Status

()

Core
Audio/Video
--
critical
RESOLVED DUPLICATE of bug 935458
2 years ago
2 years ago

People

(Reporter: Aidin Gharibnavaz, Unassigned)

Tracking

({crash})

38 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

After login to "mail.google.com", Firefox crashes after few seconds. It happens everytime.


Actual results:

Firefox crashes everytime I login into "mail.google.com". I run it under GDB, and findout that it's a "Broken pipe" error. Here's the backtrace:

#0  0x00007ffff7bd157c in send () from /lib/libpthread.so.0
#1  0x00007ffff67ed7dd in ?? () from /home/aidin/Programs/firefox/libnspr4.so
#2  0x00007ffff5a6ae32 in ?? () from /home/aidin/Programs/firefox/libssl3.so
#3  0x00007ffff5a5f36e in ?? () from /home/aidin/Programs/firefox/libssl3.so
#4  0x00007ffff5a5f77f in ?? () from /home/aidin/Programs/firefox/libssl3.so
#5  0x00007ffff5a6f4cc in ?? () from /home/aidin/Programs/firefox/libssl3.so
#6  0x00007ffff2e82f5d in ?? () from /home/aidin/Programs/firefox/libxul.so
#7  0x00007ffff2e82fd3 in ?? () from /home/aidin/Programs/firefox/libxul.so
#8  0x00007ffff1b09414 in ?? () from /home/aidin/Programs/firefox/libxul.so
#9  0x00007ffff1b0a60c in ?? () from /home/aidin/Programs/firefox/libxul.so
#10 0x00007ffff1b1590f in ?? () from /home/aidin/Programs/firefox/libxul.so
#11 0x00007ffff1b15e37 in ?? () from /home/aidin/Programs/firefox/libxul.so
#12 0x00007ffff1b16053 in ?? () from /home/aidin/Programs/firefox/libxul.so
#13 0x00007ffff179228b in ?? () from /home/aidin/Programs/firefox/libxul.so
#14 0x00007ffff1799a69 in ?? () from /home/aidin/Programs/firefox/libxul.so
#15 0x00007ffff1c97de4 in ?? () from /home/aidin/Programs/firefox/libxul.so
#16 0x00007ffff1c8ee86 in ?? () from /home/aidin/Programs/firefox/libxul.so
#17 0x00007ffff1aac368 in ?? () from /home/aidin/Programs/firefox/libxul.so
#18 0x00007ffff67eacd5 in ?? () from /home/aidin/Programs/firefox/libnspr4.so
#19 0x00007ffff7bc98ba in start_thread () from /lib/libpthread.so.0
#20 0x00007ffff6d7902d in clone () from /lib/libc.so.6
#21 0x0000000000000000 in ?? ()

I use Debian 6.0.1, amd64
I saw this with Firefox 38.0.5, and older versions.


Expected results:

It shouldn't crash.
(Reporter)

Comment 1

2 years ago
Note: Ignore the user agent and build version. I report this bug from another machine (:

Comment 2

2 years ago
Please test with a build from mozilla.org and attach the information described in the following article.
https://www.mozilla.org/firefox/all/
https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Flags: needinfo?(aidin)
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Version: 32 Branch → 38 Branch
(Reporter)

Comment 3

2 years ago
I use a Mozilla build. But to be sure, I downloaded a fresh version. I also run it in "Safe Mode", to ensure it's not the problem of any Extension.
But the error happened again.

But! This time the error is "Segmentation Fault", instead of "Broken Pipe".

*Notes:*

1)
Unfotunately, the "Crash Report" dialog couldn't send the report to the server. It gave me a "Could not connect to the server" error. But I uploaded files here:

https://github.com/aidin36/sharedstuffs/tree/master/firefox-bug

Hope you can use them.

~~~
2)
I get this error on my Terminal:

(firefox:7995): GStreamer-CRITICAL **: gst_plugin_feature_get_name: assertion `GST_IS_PLUGIN_FEATURE (feature)' failed

~~~
3)
Here's the backtrace with GDB:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffdb6fe700 (LWP 8122)]
0x00007ffff6db7356 in ?? () from /lib/libc.so.6
(gdb) backtrace 
#0  0x00007ffff6db7356 in ?? () from /lib/libc.so.6
#1  0x00007ffff27d3a2d in ?? () from /home/aidin/Desktop/firefox/libxul.so
#2  0x00007fffef64e47e in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#3  0x00007fffef6643f7 in ?? () from /usr/lib/libgobject-2.0.so.0
#4  0x00007fffef665a76 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#5  0x00007fffef665fc3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#6  0x00007fffbdc53ee4 in ?? () from /usr/lib/libgstreamer-0.10.so.0
#7  0x00007fffbd0d3468 in ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
#8  0x00007fffef64e47e in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#9  0x00007fffef6643f7 in ?? () from /usr/lib/libgobject-2.0.so.0
#10 0x00007fffef665a76 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#11 0x00007fffef665fc3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#12 0x00007fffbdc66e51 in gst_element_add_pad () from /usr/lib/libgstreamer-0.10.so.0
#13 0x00007fffef64e47e in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x00007fffef6643f7 in ?? () from /usr/lib/libgobject-2.0.so.0
#15 0x00007fffef665a76 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#16 0x00007fffef665fc3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x00007fffbc65bb68 in ?? () from /usr/lib/gstreamer-0.10/libgstdecodebin2.so
#18 0x00007fffbc65ce30 in ?? () from /usr/lib/gstreamer-0.10/libgstdecodebin2.so
#19 0x00007fffbdc79734 in ?? () from /usr/lib/libgstreamer-0.10.so.0
#20 0x00007fffbdc7bc08 in gst_pad_push_event () from /usr/lib/libgstreamer-0.10.so.0
#21 0x00007fffbbdd5e8b in ?? () from /usr/lib/gstreamer-0.10/libgstflump3dec.so
#22 0x00007fffbdc7b606 in gst_pad_send_event () from /usr/lib/libgstreamer-0.10.so.0
#23 0x00007fffbdc7bad3 in gst_pad_push_event () from /usr/lib/libgstreamer-0.10.so.0
#24 0x00007fffbdcac75e in gst_element_found_tags_for_pad () from /usr/lib/libgstreamer-0.10.so.0
#25 0x00007fffbc238239 in ?? () from /usr/lib/gstreamer-0.10/libgstmpegaudioparse.so
#26 0x00007fffbc23aa88 in ?? () from /usr/lib/gstreamer-0.10/libgstmpegaudioparse.so
#27 0x00007fffbdc7df8d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#28 0x00007fffbdc7e84e in ?? () from /usr/lib/libgstreamer-0.10.so.0
#29 0x00007fffbca9210e in ?? () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#30 0x00007fffbdc7df8d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#31 0x00007fffbdc7e84e in ?? () from /usr/lib/libgstreamer-0.10.so.0
#32 0x00007fffbdc7df8d in ?? () from /usr/lib/libgstreamer-0.10.so.0
#33 0x00007fffbdc7e84e in ?? () from /usr/lib/libgstreamer-0.10.so.0
#34 0x00007fffbd7f6711 in ?? () from /usr/lib/libgstbase-0.10.so.0
#35 0x00007fffbdca7abb in ?? () from /usr/lib/libgstreamer-0.10.so.0
#36 0x00007fffef3ce5cf in ?? () from /lib/libglib-2.0.so.0
#37 0x00007fffef3cc784 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007ffff7bc98ba in start_thread () from /lib/libpthread.so.0
#39 0x00007ffff6d7902d in clone () from /lib/libc.so.6
#40 0x0000000000000000 in ?? ()
Flags: needinfo?(aidin)
(Reporter)

Updated

2 years ago
Crash Signature: bp-d3e315e6-574b-42ef-b7ee-c2a842150609
(Reporter)

Comment 4

2 years ago
Finally, I could manage to submit a Crash Report. But not in the "Safe Mode".

bp-d3e315e6-574b-42ef-b7ee-c2a842150609

Comment 5

2 years ago
Thank you for the update.
Crash Signature: bp-d3e315e6-574b-42ef-b7ee-c2a842150609 → libc-2.11.2.so@0x10d356
Summary: Firefox receives "SIGPIPE, Broken pipe", when browsing "mail.google.com" → crash @ libc-2.11.2.so@0x10d356 | Firefox receives "SIGPIPE, Broken pipe", when browsing "mail.google.com"
(Reporter)

Comment 6

2 years ago
If it helps, I also get this error when trying to open an `mp4' inside Firefox.
Here's the report:

bp-6787b7f5-de02-4a14-8a36-c8f4e2150622

I get this error when I opened this link:
http://www.emofid.com/Downloads/videos/01-mt5-installation.mp4

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Crash Signature: libc-2.11.2.so@0x10d356 → [@ libc-2.11.2.so@0x10d356 ]
Last Resolved: 2 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 935458
You need to log in before you can comment on or make changes to this bug.