Closed Bug 1172282 Opened 6 years ago Closed 6 years ago

Warning: Unknown pseudo-class or pseudo-element 'moz-any('. Ruleset ignored due to bad selector.

Categories

(Core :: Layout: Form Controls, defect)

34 Branch
defect
Not set
normal
Points:
1

Tracking

()

VERIFIED FIXED
mozilla41
Iteration:
41.1 - May 25
Tracking Status
firefox41 + verified

People

(Reporter: philip.chee, Assigned: enndeakin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Sun Jun 07 2015 06:01:41
Warning: Unknown pseudo-class or pseudo-element 'moz-any('.  Ruleset ignored due to bad selector.
Source file: chrome://global/skin/menu.css
Line: 240, Column: 24
Source code:
menulist > menupopup > :moz-any(menuitem, menucaption):not(.menuitem-iconic) > .menu-iconic-text,
And also typo ' {' instead ',' at the end of the line
Blocks: 1172737
Blocks: 1172412
No longer blocks: 1172412
Attached patch PatchSplinter Review
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Attachment #8617400 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8617400 [details] [diff] [review]
Patch

r=me, sorry for the delay.
Attachment #8617400 - Flags: review?(gijskruitbosch+bugs) → review+
Duplicate of this bug: 1172737
https://hg.mozilla.org/mozilla-central/rev/c0609bb2fc75
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Adding a tracking flag for FF41 to make sure we get coverage on the fix.
Keywords: regression
Adding a qe-verify so it gets regressed by QE team.
Flags: qe-verify+
Points: --- → 1
Verified as fixed using Firefox 41 beta 3 under Win 7 64-bit and Mac OSX.

Also checked that bug 1172737 is no longer reproducible on Mac OSX 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.