[Music] [Front-end] Disable the fade-in animation for album art

VERIFIED FIXED in 2.2 S14 (12june)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dkuo, Assigned: dkuo)

Tracking

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(6 attachments)

(Assignee)

Description

4 years ago
In bug 1168549 we enable a fade-in animation on the album art of tiles and list views. And because the update logic(update every 25 songs) in tiles view, it might cause confusion to the users so let's disable it first before we use any new logic for the tiles view.
(Assignee)

Comment 1

4 years ago
Posted file master patch
Attachment #8616581 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Comment 2

4 years ago
Posted file v2.2 patch
Attachment #8616582 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Comment 3

4 years ago
This is a followup of bug 1168549 so also uplift to v2.2.
blocking-b2g: --- → 2.2?
Comment on attachment 8616581 [details] [review]
master patch

r=me, although it's probably ok if we kept the animation for the list views. Still, I think the only place we really *need* animation is in the player view.
Attachment #8616581 - Flags: review?(squibblyflabbetydoo) → review+

Updated

4 years ago
Attachment #8616582 - Flags: review?(squibblyflabbetydoo) → review+
ni? Dominic - I think you need to ask for approval now? (rather than 2.2?)
Flags: needinfo?(dkuo)
(Assignee)

Comment 6

4 years ago
(In reply to Dave Hylands [:dhylands] from comment #5)
> ni? Dominic - I think you need to ask for approval now? (rather than 2.2?)

Yes, Dave, you are correct, thanks for noticing!
Flags: needinfo?(dkuo)
(Assignee)

Comment 7

4 years ago
Comment on attachment 8616582 [details] [review]
v2.2 patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): A followup of bug 1168549.
[User impact] if declined: The fade-in animation in the tiles view might confuses the users if it refreshes.
[Testing completed]: two lines patch with try server passed.
[Risk to taking this patch] (and alternatives if risky): low.
[String changes made]: none.
Attachment #8616582 - Flags: approval-gaia-v2.2?
(Assignee)

Comment 8

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/1f89a95440766ad03a6406191588ee57ba6cbab0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Hi Norry,
Can you provide a video about the issue here on 2.2?
Thanks
Flags: needinfo?(fan.luo)
Posted video verify_v2.2.mp4
Hi Josh,

    I upload the video (at 00:41~01:00) and logcat about Flame v2.2, please check, thanks.


Device: Flame v2.2 build(affected)
Build ID               20150611162501
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3478f3c355c2
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150611.195621
Firmware Date          Thu Jun 11 19:56:31 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(fan.luo)
Flags: needinfo?(jocheng)
Hi Norry,
I thought we already agreed to attach video as 3gp format. Why is Shally still attach mp4 video?
Flags: needinfo?(jocheng) → needinfo?(fan.luo)

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Keywords: verifyme
Comment on attachment 8616582 [details] [review]
v2.2 patch

2.2+ as this is follow up bug for bug 1168549
Attachment #8616582 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Posted video verify_v2.2.3gp
Hi Josh,

I upload a .3gp file instead of the attachment 8621425 [details]: verify_v2.2.mp4
Flags: needinfo?(fan.luo)
Verified on Flame 3.0 that Music app no longer displays any kind of effect for album arts on tile or list views.

Device: Flame
BuildID: 20150612010203
Gaia: 9f36b711af7597a6a32471c3305cf1e2d6947d39
Gecko: 0093691d3715
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Leaving verifyme keyword for v2.2 verification after uplifting.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Target Milestone: --- → 2.2 S14 (12june)
This bug has been verified as "pass" on latest Nightly build of Flame v2.2.

See attachment: verified_v2.2.3gp
Reproduce rate: 0/5

STR:
1.Copy many music files into device.
2.Launch Music app.
**No the fade-in animation for album art.


Device: Flame v2.2 build(Verified as "pass")
Build ID               20150615162504
Gaia Revision          e7a0c6d5f4df04d45fb3f726efb9e8223600cb79
Gaia Date              2015-06-15 06:12:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8045028bf400
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150615.194936
Firmware Date          Mon Jun 15 19:49:47 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.