"LiveReload" add-on does not work with e10s

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: kontakt, Unassigned)

Tracking

({addon-compat})

40 Branch
x86_64
Mac OS X
addon-compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Injection of LiveReload's script tag at the bottom of the page does not work in e10s thus breaking its functionality.

Comment 1

3 years ago
I don't undertand the author of this add-on didn't update his addon to the latest version on AMO...
https://addons.mozilla.org/en-us/firefox/addon/livereload/
On his website, he wrote:
"warning: older extensions won’t autoupdate; please remove the old one and download and install the new one manually."
Blocks: 905436
Keywords: addon-compat
(Reporter)

Comment 2

3 years ago
After updating the LiveReload extension to version 2.1.0 from the author's website it works flawlessly with E10S enabled in Firefox 40.0a2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 3

2 years ago
Does not work for me and is a real show stopper from using Developer Edition instead of normal Firefox for Development. See https://github.com/livereload/livereload-extensions/issues/36#issuecomment-216513756

Could you pls recheck if it is really working for you with e10s?
Flags: needinfo?(kontakt)

Comment 4

2 years ago
I had email conversation with the reporter (kontakt(at)...) He does not use LiveReload anymore, so he cannot verify. I reopen because it's broken for me with e10s and others, see https://github.com/livereload/livereload-extensions/issues/36
Flags: needinfo?(kontakt)

Comment 5

2 years ago
@Loic: Could you please reopen, I don't have the permission to do so
Flags: needinfo?(epinal99-bugzilla2)

Updated

2 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(epinal99-bugzilla2)
Resolution: WORKSFORME → ---
I'm not sure if this add-on is maintained anymore. The last commit happened over a year ago, issues are left without a reply and its AMO page at https://addons.mozilla.org/en-us/firefox/addon/livereload/ urges people to uninstall the AMO version and download the one from the author site which... won't work as it's not signed; the AMO version was in fact updated and at least works outside of e10s.

This all makes it for a very confusing experience.

Comment 7

a year ago
Just for the record: I've been working with LiveReload the last months on a daily basis. So it works (now) with current Firefox Developer Edition, which has e10s enabled. Just make sure that you try to connect to the livereload server while it is "waiting" and not running any tasks.

The addon itself seems unmaintained. But since it is working I do not think it is a showstopper for the e10s rollout, I'm hence closing.
Status: REOPENED → RESOLVED
Last Resolved: 3 years agoa year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.