shadowRoot.cloneNode() creates a DocumentFragment object, not ShadowRoot

RESOLVED DUPLICATE of bug 1176757

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1176757
2 years ago
a year ago

People

(Reporter: smaug, Unassigned)

Tracking

(Blocks: 1 bug)

36 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=c++])

Comment hidden (empty)
(Reporter)

Updated

2 years ago
Blocks: 811542
(Reporter)

Updated

2 years ago
Whiteboard: [good first bug][lang=c++]

Comment 1

2 years ago
Hey, I'd love to have a go at this.

I shall dig into the source tonight and see what I can come up with.  Pointers are obviously appreciated.

Sam

Comment 2

2 years ago
Actually, it seems the current version of the spec says:

"Invoking the cloneNode() method on a ShadowRoot instance must always throw a DATA_CLONE_ERR exception.". [1]

Maybe I'll wait for the spec to settle a little, but I'll have a go at implementing what the spec currently says as a familiarity exercise.

[1] http://w3c.github.io/webcomponents/spec/shadow/

Comment 3

2 years ago
Obsoleted by: https://bugzilla.mozilla.org/show_bug.cgi?id=1176757

Comment 4

2 years ago
If this has been obsoleted should its status be changed from NEW?
Since this has already been addressed in bug 1176757, closing as a duplicate of that bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176757
You need to log in before you can comment on or make changes to this bug.