Closed Bug 1172822 Opened 5 years ago Closed 4 years ago

crash in PL_DHashTableSearch(PLDHashTable*, void const*) | mozilla::dom::indexedDB::::DatabaseConnection::GetCachedStatement

Categories

(Core :: Storage: IndexedDB, defect, critical)

40 Branch
Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1256049
Tracking Status
firefox40 --- affected
firefox41 --- affected

People

(Reporter: nigelb, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2d1f37c0-dbfd-484d-a713-e5a6b2150609.
=============================================================
Version: Trunk → 40 Branch
Crash Signature: [@ PL_DHashTableSearch(PLDHashTable*, void const*) | mozilla::dom::indexedDB::::DatabaseConnection::GetCachedStatement] → [@ PL_DHashTableSearch(PLDHashTable*, void const*) | mozilla::dom::indexedDB::::DatabaseConnection::GetCachedStatement] [@ nsInterfaceHashtable<T>::Get(nsACString_internal const&, mozIStorageStatement**) ]
Philipp notes in the other bug that this is showing up on the beta topcrash list. It's probably too late for 40 but maybe we could do something for 41.

At first glance it looks like  mDatabaseInfo->mConnection is null in CheckpointConnectionRunnable::Run?

Is this just a null check or is there some deeper invariant being broken here?
Flags: needinfo?(khuey)
CheckpointConnectionRunnable was rewritten in https://hg.mozilla.org/mozilla-central/rev/35797ae0b66f which is on what is today Aurora, and I imagine its too late to fix anything in beta even if we did know what was going wrong, so I'm not inclined to investigate much.
Flags: needinfo?(khuey)
is this rewrite supposed to mitigate this type of crash? the nsInterfaceHashtable<T>::Get(nsACString_internal const&, mozIStorageStatement**) signature is still appearing in aurora and nightly versions...
Do you have a crashstats link?
Flags: needinfo?(madperson)
Thanks.  Those to appear to be the same problem in the new code.
Crash Signature: [@ PL_DHashTableSearch(PLDHashTable*, void const*) | mozilla::dom::indexedDB::::DatabaseConnection::GetCachedStatement] [@ nsInterfaceHashtable<T>::Get(nsACString_internal const&, mozIStorageStatement**) ] → [@ PL_DHashTableSearch(PLDHashTable*, void const*) | mozilla::dom::indexedDB::::DatabaseConnection::GetCachedStatement] [@ nsInterfaceHashtable<T>::Get(nsACString_internal const&, mozIStorageStatement**) ] [@ nsInterfaceHashtable<T>::Get(nsACString_inte…
Crash Signature: , mozIStorageStatement**) ] [@ nsInterfaceHashtable<T>::Get(nsACString_internal const&, mozIStorageAsyncStatement**) ] → , mozIStorageStatement**) ] [@ nsInterfaceHashtable<T>::Get(nsACString_internal const&, mozIStorageAsyncStatement**) ] [@ PL_DHashTableSearch | mozilla::dom::indexedDB::::DatabaseConnection::GetCachedStatement] [@ nsInterfaceHashtable<T>::Get ]
It seems bug 1256049 has a fix for this.
Depends on: 1256049
Flags: needinfo?(jvarga)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256049
You need to log in before you can comment on or make changes to this bug.