Closed Bug 1172847 Opened 4 years ago Closed 4 years ago

'Let’s Talk About' hard to see in conversation window after someone joins the conversation due to its color

Categories

(Hello (Loop) :: Client, defect, P2)

defect
Points:
1

Tracking

(firefox40+ verified, firefox41 unaffected, firefox42 unaffected)

VERIFIED FIXED
mozilla40
Iteration:
42.2 - Jul 27
Tracking Status
firefox40 + verified
firefox41 --- unaffected
firefox42 --- unaffected

People

(Reporter: bogdan_maris, Assigned: mikedeboer)

References

Details

(Whiteboard: [ux bug])

Attachments

(2 files)

Affected builds:
- Latest Nightly 41.0a1
- Latest Aurora 40.0a2

Affected OS`s:
- Windows 7 64-bit
- Mac OS X 10.9.5
- Ubuntu 14.04 32-bit

STR:
1. Start Firefox
2. Visit a website and tick 'Let’s Talk About'
3. Start a conversation
4. Join the conversation from same or different PC

Expected results: 'Let’s Talk About' visible in conversation window.

Actual results: 'Let’s Talk About' is colored black and it`s very hard to see.

Notes:
- Screenshot showing the issue: image from left is before bug 1162909 and image from right is the actual behavior.
- This is not a regression, it reproduces after context layout changes in bug 1162909.
Rank: 24
Flags: qe-verify+
Flags: firefox-backlog+
Priority: -- → P2
Whiteboard: [ux bug]
This will be fixed by the redesign in bug 1171940.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171940
Re-opening and make it apply only to Fx 40. Other (newer) versions of Fx will be fixed by bug 1171940, as stated in comment 1.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
[Tracking Requested - why for this release]:
Nominating Hello Conversation Context issues for 40.
Iteration: --- → 42.2 - Jul 27
Points: --- → 1
Assignee: nobody → mdeboer
Status: REOPENED → ASSIGNED
Comment on attachment 8634069 [details] [diff] [review]
Patch v1: make sure that the color of context in conversations label is white. Beta-only!

Review of attachment 8634069 [details] [diff] [review]:
-----------------------------------------------------------------

r=dmose; thanks for the quick patch!
Attachment #8634069 - Flags: review?(dmose) → review+
Comment on attachment 8634069 [details] [diff] [review]
Patch v1: make sure that the color of context in conversations label is white. Beta-only!

Approval Request Comment
[Feature/regressing bug #]: Hello context in conversations feature
[User impact if declined]: When the conversation is connected on both sides and the context view is visible in the conversation window, the label is barely visible, because it's color is black. There was a CSS rule missing, which this patch puts in place.
[Describe test coverage new/current, TreeHerder]: zip, since m-a does not exhibit this bug once bug 1171940 is uplifted there.
[Risks and why]: minor, this is quite possibly the simplest CSS change you can imagine.
[String/UUID change made/needed]: n/a.
Attachment #8634069 - Flags: approval-mozilla-beta?
Comment on attachment 8634069 [details] [diff] [review]
Patch v1: make sure that the color of context in conversations label is white. Beta-only!

We want this new feature to be polished, taking it.
Attachment #8634069 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
This has already landed in 40. Tracking in case this is reopened.
Verified that the issue is fixed on Firefox 40 beta 6 across platforms (Windows 10 32-bit, Windows 8.1 64-bit, Mac OS X 10.10 and Ubuntu 14.04 32-bit).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.