<esc> is bound to split console, but conflicts with Vim mode

RESOLVED DUPLICATE of bug 972534

Status

()

Firefox
Developer Tools: Source Editor
RESOLVED DUPLICATE of bug 972534
3 years ago
3 years ago

People

(Reporter: \, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

STR:

* open dev tools
* go to settings
* set keybindings to vim
* go to style editor
* add some style (press i to enter insert mode)
* press escape to leave insert mode

Expected:
Back in normal mode

Actual:
Split console opened

Note, this happens even if I hide the split console option from the UI in settings, and with other tools as well other than just the style editor.
Note that bug 962157 was also filed for the opposite problem (CodeMirror keybinding overriding toolbox keybinding).
Component: Developer Tools: Style Editor → Developer Tools: Source Editor
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 972534
You need to log in before you can comment on or make changes to this bug.