Closed Bug 1173120 Opened 6 years ago Closed 6 years ago

devicemanagerADB._runCmd() does not use a timeout

Categories

(Testing :: Mozbase, defect)

defect
Not set
normal

Tracking

(firefox41 fixed)

RESOLVED FIXED
mozilla41
Tracking Status
firefox41 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

http://hg.mozilla.org/mozilla-central/annotate/517791f65cd9/testing/mozbase/mozdevice/mozdevice/devicemanagerADB.py#l542

devicemanagerADB's _runCmd() does not take a timeout argument and does not use a timeout argument when calling ProcessHander.run() -- unlike _checkCmd() and perhaps some other places. I think that means that an adb hang will translate into a test harness hang, resulting in the dreaded buildbot 2400 seconds without output timeout in automation.
See Also: → 1172174
This updates devicemanagerADB's _runCmd to use a time-out when running adb -- just like _checkCmd, after bug 1172174.
Attachment #8620989 - Flags: review?(armenzg)
Attachment #8620989 - Flags: review?(armenzg) → review+
https://hg.mozilla.org/mozilla-central/rev/c1dc1b681579
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Duplicate of this bug: 1051908
You need to log in before you can comment on or make changes to this bug.