Closed Bug 1173156 Opened 4 years ago Closed 4 years ago

[Messages] Unable to send SMS from Sim 2 unless Sim 1 is present and unlocked

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox41 fixed, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S1 (26Jun)
Tracking Status
firefox41 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: AdamA, Assigned: freesamael)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files, 2 obsolete files)

Attached file logcat
Summary (title) Field:
[Messages] Unable to send SMS from Sim 2 unless Sim 1 is present and unlocked

Description:
If the user tries to send an SMS from Sim 2 but doesnt have a Sim in slot 1, or the sim is locked, they will be unable to send a message.


Repro Steps:
1) Update a Flame to 20150608160934
2) Make sure the phone has 2 sim cards and the one in slot 1 has a sim pin
3) Enter the messages app skip unlocking Sim 1 (unlock Sim 2 if it has a pin)
4) Write a message and Hold the send button to bring up the sim selector
5) Select to send the message from sim 2
6) Observe message not sending


Actual:
Messages from Sim 2 will not send unless sim 1 is present and unlocked


Expected:
It is expected that users can send messages from Sim 2 with Sim 1 locked or not present.


Environmental Variables:
Device: Flame 3.0 (Full Flash)
Build ID: 20150608160934
Gaia: ea27c4ed5b6083c9e21d233d4804372ac4d5d353
Gecko: e10e2e8d8bf2
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/U30CWtWkGWI), logcat
This issue DOES NOT occur in Flame 2.2, 2.1, or 2.0.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150608162505
Gaia: 06edb0f8db7c2f45cde54401a8593663059861a4
Gecko: 239c59921129
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150608161203
Gaia: f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gecko: 35e91d3657f5
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150608160805
Gaia: 5552bf529d3d6775a968942e9afa6c1d4037362c
Gecko: 73c77853d35d
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
The SMS sends from Sim 2.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [3.0-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Functional regression.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
Why is it labelled as "Spark"? As far as I know the Aries device does not have 2 SIM slots?

(note that I'm not saying this bug is unimportant!).
I'm sorry, I accidentally added that tag. I have removed it, this issue is not occurring on the spark device.
Whiteboard: [3.0-Daily-Testing][Spark] → [3.0-Daily-Testing]
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150526063313
Gaia: f84772d2640d825eaf3f9fcd906b4756e19e8a3f
Gecko: 495d30d48807
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame
BuildID: 20150526084713
Gaia: f84772d2640d825eaf3f9fcd906b4756e19e8a3f
Gecko: b2fd7795465f
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=495d30d48807&tochange=b2fd7795465f

Caused by patches for bug 1152730.
Blocks: 1152730
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Samael, can you take a look at this please? This might have been cauased by the landing for bug 1152730.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(sawang)
That's embarrassing. It turns out to be a typo which causes the issue. I'm going to add a multi-sim test case to address this case.
Assignee: nobody → sawang
Flags: needinfo?(sawang)
Component: Gaia::SMS → RIL
Comment on attachment 8620894 [details] [diff] [review]
Fix typo and add a Marionette test case

Hi Bevis,

Would you help to review the patch and test case?
Attachment #8620894 - Flags: review?(btseng)
Comment on attachment 8620894 [details] [diff] [review]
Fix typo and add a Marionette test case

Review of attachment 8620894 [details] [diff] [review]:
-----------------------------------------------------------------

Just found another typo for the naming of SmsSendingSchedular.
Please have all "schedular"s renamed to "scheduler"s.

Please also remove unnecessary debugging message. 

Thanks!

::: dom/mobilemessage/gonk/SmsService.js
@@ +1290,5 @@
>      while ((req = snapshot.shift())) {
> +      if (DEBUG) {
> +        debug("sending message: messageId=" + req.messageId +
> +          ", serviceId=" + this._serviceId);
> +      }

No need for this debug message.
You can print the |aServiceId| in onSend() where the messageId has already been printed with |aDomMessage.id|.
Attachment #8620894 - Flags: review?(btseng)
Attachment #8622291 - Attachment description: Fix typo and add a Marionette test case → (v2) Fix typo and add a Marionette test case
Attachment #8620894 - Attachment is obsolete: true
Comment on attachment 8622291 [details] [diff] [review]
(v2) Fix typo and add a Marionette test case

Hi Bevis,

Could you help to review the updated patch?
Attachment #8622291 - Flags: review?(btseng)
Comment on attachment 8622291 [details] [diff] [review]
(v2) Fix typo and add a Marionette test case

Review of attachment 8622291 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the nits addressed.

Thanks!

::: dom/mobilemessage/gonk/SmsService.js
@@ +338,5 @@
>        .schedule({
>          messageId: aDomMessage.id,
>          onSend: () => {
> +          if (DEBUG) debug("onSend: messageId=" + aDomMessage.id +
> +            ", serviceId=" + aServiceId);

nit: align as followed with {}, let the strings have the same alignment to '"' in new line:
          if (DEBUG) {
            debug("onSend: messageId=" + aDomMessage.id +
                  ", serviceId=" + aServiceId);
          }

@@ +1252,5 @@
>    schedule: function(aSendingRequest) {
>      if (aSendingRequest) {
> +      if (DEBUG) {
> +        debug("scheduling message: messageId=" + aSendingRequest.messageId +
> +          ", serviceId=" + this._serviceId);

nit: align strings to '"' in the new line.
Attachment #8622291 - Flags: review?(btseng) → review+
Attachment #8622291 - Attachment is obsolete: true
Attachment #8622373 - Attachment description: Fix typo and add a Marionette test case → (v3) Fix typo and add a Marionette test case, r=btseng
Attachment #8622373 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/a312bb7e2c14
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → NGA S3 (26Jun)
This bug has been verified as "pass" on latest Nightly build of Flame v3.0 by the STR in Comment 0.

Actual results: Device can send out SMS from SIM 2 even though SIM 1 is unlocked.
See attachment: verified_v3.0.3gp
Reproduce rate: 0/10


Device: Flame v3.0 build(Pass)
Build ID               20150616160206
Gaia Revision          9d42e94446f2dc01b519172b6d75d81d4d435bdc
Gaia Date              2015-06-16 16:16:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/27caa5299f9f
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150616.194325
Firmware Date          Tue Jun 16 19:43:36 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
As NGA Program Manager suggested, let's replace the NGA-Sx milestones with FxOS-Sx ones (more generic ones), once Bug 1174794 has already landed
Target Milestone: NGA S3 (26Jun) → FxOS-S1 (26Jun)
blocking-b2g: 2.5? → ---
This issue is verified fixed in Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
Build ID: 20150827083151
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: b33eae31bd71
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
Users can send messages from sim 2 with sim 1 locked.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.