MSE & Webm VP9 Firefox only shows first video frame and doesn't start playing

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: felix.bau, Unassigned)

Tracking

(Blocks: 1 bug)

38 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8617642 [details]
Bildschirmfoto - 10.06.2015 - 01:07:06.png

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150603135725

Steps to reproduce:

I played a youtube video but it didn't start


Actual results:

only the first video frame was shown/decoded (sometimes the video screen also just stays black)
the video was downloaded in the background (the grey bar that showed the loading progress got wider, statistics for nerds shows that it loads but doesn't decode)


Expected results:

if I deactivate MSE for webm then the playback works just fine
but youtube only provides vp8 with 360p in such a case sadly

another way to work around this for now is:
enforcing flash by using the YouTube Center addon (YTC)

I'm using Fedora 21 with Firefox 38.0.5
(Reporter)

Updated

4 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core

Comment 1

4 years ago
I can reproduce but this is likely a duplicate of one of those other blocking bugs listed here: https://bugzilla.mozilla.org/show_bug.cgi?id=778617
Firefox does not yet support MSE for VP9, but we're working on it. :)
Depends on: 833023
(Reporter)

Comment 3

4 years ago
Thanks for your answer
and sorry for my late answer
but why does YouTube then detect, that my browser supports it and delivers it, even though I cannot play it?

https://www.youtube.com/html5

I mean of course it only does so, because I enabled it in the about:config, but shouldn't it still refuse it then? (because it doesn't work)


btw. on windows (beta) MSE + VP9 works just fine for me (if that information is helpful)

anyways looking forward to MSE being fully supported :)
With the most recent nightly on Linux, with media.mediasource.webm.enabled = true, this bug no longer reproduces. Could you try again and see if it is resolved for you too?
WebM should be working correctly in latest nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 6

4 years ago
Broken Youtube VP9 playback on Archlinux 64bit

Comment 7

4 years ago
Works now
You need to log in before you can comment on or make changes to this bug.