Small Background Objects Slow Scrolling when Repetitively Redrawn




17 years ago
4 years ago


(Reporter: jeff givens, Assigned: dcone (gone))


(Blocks: 1 bug, {perf})

Windows 98

Firefox Tracking Flags

(Not tracked)




(2 attachments)



17 years ago
The above site when scrolled (unless done *very* slowly) is extremely jerky in
redrawing the page. This is true in both Moz 0.9.6+ and NS 6.2.

Investigation showed that the background image, tile.gif, is 6 x 1500 (wot the
heck was this designer doing????) causing the image to be redrawn roughly a
schmillion times for a full page redraw.

I edited the page and cloned the background image to make one maybe 600 or so
pixels tall and using this image locally the page scrolls nicely.

No problem scrolling in IE 5.5.

Comment 1

17 years ago
Created attachment 63031 [details]
background used to show scrolling fix

Comment 2

17 years ago
Forgot to add I'm on a P4 1.7, 98SE, ATI all-in-wonder Radeon 32M.
Is it just as bad in current trunk builds?  There have been bugs filed on 
similar issues before and at least some are fixed...

Comment 4

17 years ago
Sorry, but I haven't used ay of the overnights so I can't comment on their
performace in this matter.

Comment 5

17 years ago
OK - my curiosity of the nightly builds got the better of me so I tried
2001122908, which didn't fix the problem, still jerky.

Comment 6

16 years ago
Very strange... Scrolling is fine for me, Win98SE, 2001122703 (and GeForce2MX,
if that matters...)

Comment 7

16 years ago
Perhaps your video performance is enough to overcome the jerkiness although the
ATI AIW Radeon is no slouch either.

Comment 8

16 years ago
Assignee: asa → attinasi
Component: Browser-General → Layout
Ever confirmed: true
Keywords: perf
QA Contact: doronr → petersen

Comment 9

16 years ago
*** Bug 120054 has been marked as a duplicate of this bug. ***
Reassigning to Don.
Assignee: attinasi → dcone
Target Milestone: --- → mozilla1.0


16 years ago
Blocks: 100951
This is most likely caused by a regression which resulted in no longer calling
patblt on WIN32. It also is not using the cross-platform code which quickly
replicates the background image into a larger tile.
Keywords: nsbeta1+

Comment 12

16 years ago
I ran this page on both explorer 6.0 and Mozilla.  I found the following:
1.) There is an animated GIF that seems to make both browsers render chunky.. 
but if you scroll down to where the animated GIF is not seen... both pages 
scroll fast.

2.) The two browsers render the page differently.. its probably a layout bug.. 
but its definetly different.. and it could be one of the causes of the chunky 

3.) The speed may or may not be identical to explorer..but it seems to me -- 
very simular.. the only way I could think to increase this speed much more is to 
cache the tiles we create to increase the blitting speed.  I dont think that the 
differences are enough to warrent that.

In conclusion.. I dont think this is a bug for Windows 98.  Windows 2k, NT and 
XP.. OS's will get faster when I fix the background bugs by using the PatBlt 
call... which 98 does not support.  I am marking this wont fix. 
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Target Milestone: mozilla1.0 → mozilla1.2

Comment 13

16 years ago
dcone: is there a bug # for the fix you are planning to do?

Comment 14

16 years ago
From bug 120054 :
Changed URL to

This page has a tiny background image repeated many times.   Scrolling is
extremely slow.   Re-opening.    If I am out of line, feel free to change it
back.   But I feel that this is definately an issue.  IE and NS 4.x have no
slowness whatsoever scrolling the very same page.
Resolution: WONTFIX → ---

Comment 15

16 years ago
This very same PC when running NT4 SP6 *does not* exhibit the scrolling problem.
Have to check which video driver but if I remember it is the same as the 98SE one.

In terms of animated gifs and page locations, the original posted espn page
still shows the jerkiness no matter what part of the page is being viewed when
scrolled.  The jerkiness is really bad, sometimes a second or so for the redraw,

The lindows link given suprisingly gives very little trouble for me, almost, but
not quite, being smooth.

Comment 16

16 years ago
I am working on NT4 SP6 with a PII 400 / 380 MB RAM and 
the lindows link is really slow scrolling on my box...
On the same box, with IE the page scrolls fine with minimal
CPU usage
On linux, with a PIII 733 / 128 MB RAM everything is fine too.

Comment 17

16 years ago
Let me get this straight.

For Jeff Givens.. Windows 98 is slow.  Windows NT is fine.  This makes sense 
since NT uses a PatBlt for the background tiling of small images.

for Andrea Aime.. Windows NT is extremely slow.  Could be a video card 
incompatibily.  I dont understand this at all.  What pull are you using.

WD -- what OS and pull are you using?  Describe what slow is for you.. are you 
seeing 1 second delays, or a chunkiness?

For me.. 98 (400 pII) is a tad chuncky.. but no noticible delays.  NT(400 PII) 
.. smooth as silk.  W2K(1500 athlon) smooth as silk.

I just had a few other run 98 and they did not notice any chunkiness with 98 400 
PII.. but I think the chunkiness I saw was just under there radar.  

Before I disposition this bug.. I will run on a few more machines.. NT 4.0 and 
up and see what I can see.   

Comment 18

16 years ago
Ok, some more info: my box has a Matrox G100 video card
driving a 19'' Monitor (sounds a bit strange, I now, 
but that's the way it goes, I cannot change it... :-(
Now, it's supposed to be a low end one, but let me repeat
that IE runs on the same hardware and it is smooth as
silk, while Mozilla is slow, slow, slow (only on this
page, usually I cannot see any speed difference between
IE5 and Mozilla). They do run on the same machine,
so the hardware is for sure not the only problem...
BTW, I'm running Moz 2002022703...

Comment 19

16 years ago
For our tiling we use a PatBlt if the machine is NT (NT 4.0, W2K, XP).  I pulled 
the PatBlt for windows 98 because people were having video driver 
incompatibilities (machines with bad drivers would crash,those with the 
correct drivers would blaze, this was a documented Windows Bug).. so there was 
some sacrifice in speed.  One theory here might be that your having a video 
driver problem on your NT box.  Your comparing apples and oranges when you say 
Explorer works fast and we don't.  They could and probably do have a competely 
different architecture as far as what they have in memory.  They could have an 
entire page buffered offscreen, etc.  We re-render every single time you scroll 
to an offscreen buffer. Mozilla depends on very fast blitting and rendering of 
tiles.  For small background images we blit a trillion times..thats just the way 
it is.  For now I want to find out why your having difficulties compared to 
other mozilla users.. not compared to other software.

Comment 20

16 years ago
Created attachment 72676 [details] [diff] [review]
Patch to get NT to PatBlt no matter what tile size.
Comment on attachment 72676 [details] [diff] [review]
Patch to get NT to PatBlt no matter what tile size.
Attachment #72676 - Flags: review+


16 years ago
Target Milestone: mozilla1.2 → mozilla1.0

Comment 22

16 years ago
Comment on attachment 72676 [details] [diff] [review]
Patch to get NT to PatBlt no matter what tile size.

sr=attinasi, but please update the comment to reflect all of the cases in that
complex 'if' statement
Attachment #72676 - Flags: superreview+

Comment 23

16 years ago
Comment on attachment 72676 [details] [diff] [review]
Patch to get NT to PatBlt no matter what tile size.

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #72676 - Flags: approval+
The patch was checked in.
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 25

16 years ago
On Win2k, scrolls
*extremely* slow.   Moz is nearly unusable on my Athlon 1800+ / Geforce 256 on
that page.   Build 2002032103

No DHTML or anything goofy.  Just a small image repeated as a background:

Resolution: FIXED → ---
WFM: Using cvs release build on 3/23 it scrolls smoothly on 750Mhz athlon.

Comment 27

16 years ago works almost ok for me on
the offending win98 box. A tiny bit jerky but nothing like the example.

Speaking of which, something of interest:

The other day on the win98 box that all this was reported upon, the espn page
scrolled nice and smooth, no problems at all. I thought maybe the changed their
page with a different background image. I did file, edit page, and Moz crashed.
Upon resarting the jerkiness is back and remains. Odd.

Comment 28

16 years ago
Page scrolls fine(little jerkiness) for me on my 400 NT 4.0 machine.  I think 
maybee somekind of driver issue.. with some offending machines.  My Athlone 
1500 with a GForce II scrolls very smoothly.

Comment 29

16 years ago
I am marking this works for me.. and then I opened another bug which I think is 
the only right way to solve this bug... 133261.  I dont think I can go much 
further with PatBlt and the cacheing in 133261 is the only way to go as far as I 
can tell.
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 30

16 years ago
Marking verified wfm with the April 23nd build (2002-04-23-06) under Windows ME.
You need to log in before you can comment on or make changes to this bug.