Closed Bug 1173841 Opened 4 years ago Closed 4 years ago

[Spark][OTA] Pre-installed dogfood apps are not correctly deleted (they are not on the homescreen anymore but still in Activities and Apps permissions)

Categories

(Core Graveyard :: DOM: Apps, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+)

RESOLVED WORKSFORME
blocking-b2g 2.5+

People

(Reporter: jlorenzo, Unassigned)

Details

(Keywords: foxfood, Whiteboard: [spark][systemsfe])

Attachments

(1 file)

STR
1. On the homescreen, delete Facebook, Twitter and Try What's app
2. Open the gallery and share a photo

Results
Even though the apps are supposed to be deleted, they still appear in the activity picker. See attached screenshot.

Build info
This doesn't reproduce on freshly flashed device, but only on device I OTA'd for 10 days. This device is currently at:
Build ID               20150611041939
Gaia Revision          d2f31eb85837aae6eca04d022d1f5b2023bc778c
Gaia Date              2015-06-10 19:57:58
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bfd82015df48
Gecko Version          41.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150605.140045
Firmware Date          Fri Jun  5 14:00:54 UTC 2015
Bootloader             s1
Component: Gaia → Gaia::System::Status bar, Utility tray, Notification
It turns out that these apps are still installed: I found them in Settings -> Apps Permissions. From there, I could uninstall them and they don't appear on the activity picker anymore. 

In other words, there was a problem of uninstallation. This might be another dupe of bug 1154055. What do you think :cwiis? If not, I'll continue finding some steps.
Component: Gaia::System::Status bar, Utility tray, Notification → Gaia::Homescreen
Flags: needinfo?(chrislord.net)
Summary: [Spark] Pre-installed dogfood apps are still present in the share menu, even though there are supposed to be deleted → [Spark][OTA] Pre-installed dogfood apps are not correctlu deleted (they are not on the homescreen anymore but still in Activities and Apps permissions)
[Blocking Requested - why for this release]: causes extraneous issues.  Most likely from OTAing?  

QAWanted: to check what happens when starting from a day or two ago instead.
Current dogfood is set to : 20150611132111
Which can be gotten here : https://tools.taskcluster.net/task-inspector/#msRav0dLSEWWGd195lUdxA/0
You can then switch the channel to dogfood-latest and get an OTA.

I think that might be a different bug Johan.  I guess we'll wait for confirmation from Chris.
[Blocking Requested - why for this release]:
blocking-b2g: --- → spark?
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #1)
> It turns out that these apps are still installed: I found them in Settings
> -> Apps Permissions. From there, I could uninstall them and they don't
> appear on the activity picker anymore. 
> 
> In other words, there was a problem of uninstallation. This might be another
> dupe of bug 1154055. What do you think :cwiis? If not, I'll continue finding
> some steps.

I would say that the homescreen not handling this correctly is bug 1154055, but perhaps there's another bug that leads to the situation where the homescreen doesn't handle this? (because I've never seen this behaviour in 2.2 or before, and I would've thought it may have come up before now).

Perhaps we should use this bug to track the latter? I'll still try to make sure the homescreen doesn't fall over this though.
Flags: needinfo?(chrislord.net)
Keywords: foxfood
Keywords: dogfood
blocking-b2g: spark? → 2.5?
QA Whiteboard: [foxfood-triage]
blocking-b2g: 2.5? → 2.5+
Whiteboard: [spark] → [spark][systemsfe]
Component: Gaia::Homescreen → Gaia::System
Priority: -- → P2
Per comment 4, either Homescreen does not uninstall the app by calling the API correctly, or Apps API did not handle the uninstall/OTA upgrade correctly. Either way this can't be handled in Gaia System.
Component: Gaia::System → Gaia::Homescreen
Summary: [Spark][OTA] Pre-installed dogfood apps are not correctlu deleted (they are not on the homescreen anymore but still in Activities and Apps permissions) → [Spark][OTA] Pre-installed dogfood apps are not correctly deleted (they are not on the homescreen anymore but still in Activities and Apps permissions)
Here's the call to uninstall in verticalhome... I don't see any way to call this incorrectly, unless I'm missing something. I suppose this is a Gecko bug in that case? https://github.com/mozilla-b2g/gaia/blob/master/apps/verticalhome/js/app_manager.js#L68
Component: Gaia::Homescreen → DOM: Apps
Product: Firefox OS → Core
Does that still reproduce?
Keywords: qawanted
QA Contact: sleedavid
No Repro per build:
Environmental Variables:
Device: Aries 2.5
BuildID: 20150921142023
Gaia: 2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gecko: fcef8ded82219c89298b4e376cfbdfba79a1d35a
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage?]
Flags: needinfo?(jmercado)
QA Contact: sleedavid
QA Whiteboard: [foxfood-triage?] → [foxfood-triage]
Flags: needinfo?(jmercado)
I cannot reproduce this issue. I flashed to RC4 build (6/19), OTA'ed via dogfood channel (8/12), deleted the 3 mentioned apps, went to Gallery to view a picture and tapped on share - those 3 apps were not listed.

Also tried deleting the 3 apps PRIOR to OTA, and found that those 3 apps came back after OTA, but if I delete them again the bug won't repro.

No repro from RC4 to:
Device: Aries 2.5
BuildID: 20150812231434
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

NI reporter to see if they're still seeing this issue.
Flags: needinfo?(jmercado)
Flags: needinfo?(jlorenzo)
Flags: needinfo?(jmercado)
I haven't reproduced since I filed the bug, but I also haven't OTA'd my dogfood device for a month. I plan to perform an update in the next days. Keeping the NI until I do.
I have done many OTAs for the last couple of weeks. Each time I deleted Facebook and Twitter, right after the update applied (bug 1172163). I've never managed to get in the same state as in comment 0.

I'm closing this bug as works for me. It happened once and never came back. If I hit it again, I'll reopen the bug.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jlorenzo)
Keywords: qawanted
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.