Closed Bug 1173907 Opened 4 years ago Closed 4 years ago

GTK3: Progress bars have strange tick

Categories

(Core :: Widget: Gtk, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: acomminos, Assigned: acomminos)

References

Details

Attachments

(2 files, 2 obsolete files)

On GTK3, progress bars are drawn with a strange tick. This appears to be caused by a call to gtk_render_activity when drawing a progress chunk.
Martin, Karl; do you seem to know why we make a call to gtk_render_activity in moz_gtk_progress_chunk_paint for all types of progress bars? It seems to be intended for activity indicators, not progress bars.
Flags: needinfo?(stransky)
Flags: needinfo?(karlt)
(In reply to Andrew Comminos [:acomminos] from comment #1)
> Martin, Karl; do you seem to know why we make a call to gtk_render_activity
> in moz_gtk_progress_chunk_paint for all types of progress bars? It seems to
> be intended for activity indicators, not progress bars.

I wonder whether you are asking about the same issue I pointed out in https://bugzilla.mozilla.org/show_bug.cgi?id=634086#c7

"indeterminate" progress bars show activity even when there is no activity.
Flags: needinfo?(karlt)
Sorry I have no idea.
Flags: needinfo?(stransky)
Since it doesn't look like the activity indicator has any purpose in drawing a progress chunk, this patch just simply removes it.
Attachment #8626216 - Flags: review?(karlt)
Comment on attachment 8626216 [details] [diff] [review]
Remove indeterminate progress indicators on progress chunks with GTK3.

This seems to be another gtk+ 3.14 theming api change.

gtk_progress_bar_paint_activity and gtk_progress_bar_paint_continuous used
gtk_render_activity prior to 3.14 and now use gtk_render_background and
gtk_render_frame.

Given we hope to support pre-3.14 versions, I don't think we should remove
support for those versions, and so version detection is probably required for
api detection.
Attachment #8626216 - Flags: review?(karlt) → review-
Blocks: 1073117
Thanks, looks like the change was made earliest in 3.13.7 with GTK commit 6c06bd55dae61ce6066555c7d4794ed9ca3911de.
Attachment #8626216 - Attachment is obsolete: true
Attachment #8632984 - Flags: review?(karlt)
Attachment #8632984 - Flags: review?(karlt) → review+
Keywords: checkin-needed
Needs rebasing on top of inbound tip.
Keywords: checkin-needed
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5a14fde78ca7
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.