Closed Bug 117391 Opened 19 years ago Closed 19 years ago

Viewing bad source when submitted form using POST method

Categories

(Core :: Networking: Cache, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 55583

People

(Reporter: root, Assigned: gordon)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7+)
Gecko/20011223
BuildID:    2001122308

Having guestbook, form on the page, post method, two elements - input type
hidden, name action, value new && submit - value new contribution.

The problem is: when action is null (means user only wants to view the
guestbook), it writes out the articles from the database (let's call this 'view
database'). When you click 'new submission', PHP writes out new form, where you
fill your name, etc ... ('new contribution')

*When I want to view the source of the 'new contribution' page, it still shows
the source of the 'view database' page ... I thought, that the problem is caused
by the proxy (squid @ another machine), but I have set up a direct connect and
the problem remains ...*

There are two same forms (on on the top, one on the bottom of the page,
described above), and one form where you can set up, how many articles should be
viewed.

Reproducible: Always
Steps to Reproduce:
1. have a page, form 'post-methoded'
2. submit the form
3. try to view the source

Actual Results:  Showed the source of the old page

Expected Results:  Huh, should view the new source ;))

The form:
<FORM METHOD="post">
<INPUT TYPE="hidden" NAME="action" VALUE="new">
<INPUT TYPE="Submit" NAME="go" VALUE="New contribution [in Czech]" CLASS="input">
</FORM>

Repeats twice on the same page, using same item names (go, action)
qa: 111466
Assignee: asa → gordon
Component: Viewer App → Networking: Cache
QA Contact: asa → tever

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.