If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SW registered from app and from same app launched via browser causes a crash in about:serviceworkers

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: about:debugging
P3
normal
RESOLVED WONTFIX
2 years ago
10 months ago

People

(Reporter: noemi, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8621464 [details]
crash_6_12_Gecko-f5cca86.Gaia-fcd90a0

STR required b2g:

1. Flash today's (6/12) master build in a Flame device
2. In the browser app, opens appA
3. appA registers a SW
4. about:sw in b2g shows up that SW
5. Install appA
6. Open appA directly, appA registers the same SW again
7. about:sw in b2g currently (once Bug 1168226 has been landed) shows up the SWs registered at step #2 and step #4 which is the expected behavior
8. Suddenly a crash occurs

It is 100% reproducible following the steps described above

The traces appearing in the console are as follows:
I/GeckoDump( 1415): Crash reporter : Can't fetch app.reportCrashes. Exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://b2g/content/shell.js :: shell_reportCrash :: line 147"  data: no]
I/Gecko   ( 1415): 
I/Gecko   ( 1415): ###!!! [Parent][MessageChannel] Error: (msgtype=0x70001C,name=PHttpChannel::Msg_ReportSecurityMessage) Channel error: cannot send/recv
I/Gecko   ( 1415): 
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]


Pleas find attached the corresponding crash report from the phone "crash_6_12_Gecko-f5cca86.Gaia-fcd90a0.zip"

Environmental variables:
Flame device
Build Id: 20150612080105
Gecko: f5cca86
Gaia: fcd90a0
Platform version: 41.0a1
(Reporter)

Comment 1

2 years ago
Hi,

After some additional tests I've seen 2 different scenarios after following the steps described above from 1 to 7 with today's (6_12) build:

*scenario #1 (it occurs from time to time, not always as said in comment 1):
a crash suddenly occurs, then the crash message is shown. The assertion seen in the traces is as follows:
F/MOZ_Assert( 1262): Assertion failure: mWorkerLoopID == MessageLoop::current()->id() (not on worker thread!), at ../../dist/include/mozilla/ipc/MessageChannel.h:418

*scenario #2 (in case scenario 1 doesn't happen, this one is almost always occurring):
From step 7, if there is no interaction with the phone, after a few minutes, the phone is automatically restarted, the same assertion is shown in the traces:
F/MOZ_Assert( 1357): Assertion failure: mWorkerLoopID == MessageLoop::current()->id() (not on worker thread!), at ../../dist/include/mozilla/ipc/MessageChannel.h:418
(Reporter)

Comment 2

2 years ago
Hi,

just adding that it is still reproducible with today's (7/13) master build.

STR in b2g:
1. Flash today's (7/13) master build in a Flame device
2. In the browser app, opens appA
3. appA registers a SW
4. about:sw in b2g shows up that SW
5. Install appA
6. Open appA directly, appA registers a SW 
7. about:sw in b2g shows up the SWs registered at step #3 and step #6 which is the expected behavior
8. Wait a few seconds without any interaction with the phone, once the screen is switched off the phone is automatically restarted

The assertion appearing is as follows:
F/MOZ_Assert( 1241): Assertion failure: mWorkerLoopID == MessageLoop::current()->id() (not on worker thread!), at ../../dist/include/mozilla/ipc/MessageChannel.h:423

Environmental variables
Flame device
Build Id: 20150713074239
Gecko: 9d932ee
Gaia: 167a22b
Platform version: 42.0a1
Clarifying summary a bit.
Summary: A crash occurs after following the steps described in Bug 1168226 → SW registered from app and from same app launched via browser causes a crash in about:serviceworkers
Since we'd like about:debugging to be the future instead of about:serviceworkers, I'm moving this bug to that component.  I'm not sure what the about:serviceworkers/about:debugging-in-Gaia's-Settings-app plan is. Francisco?
Component: DOM: Service Workers → Developer Tools: about:debugging
Flags: needinfo?(francisco)
Product: Core → Firefox
Hi Andrew,

we would probably like to support the basic functionality that we have right now.

Anyway looking forward to have support for proper debugging on dev tools for B2G, so the new component looks good to me.

Thanks.
Flags: needinfo?(francisco)
See Also: → bug 1212802
Blocking on Bug 1212802, we will need to check if this issue is still valid when connecting to remote runtimes is implemented for about:debugging.
Depends on: 1212802
Priority: -- → P3

Comment 7

10 months ago
I don't think apps exist any more, so I think this is WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.