Closed Bug 1174420 Opened 4 years ago Closed 4 years ago

SimplePush API broken on B2G

Categories

(Core :: DOM: Push Notifications, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
2.2 S14 (12june)
Tracking Status
firefox41 --- fixed

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file, 1 obsolete file)

On my devices running B2G master, FindMyDevice is never able to find my devices, even though the registration seems to be done. Further debugging in bug 1159046 shows that |navigator.push.register()| never trigger a success or error callback or Promise keep waiting.

So far I could find that PushServiceLauncher.js was never even loaded. Extracting omni.ja there is definition in the manifest for this service to be triggered upon "app-startup" but this seems not to be working.

MOZ_SIMPLEPUSH=1 is present in objdir-gecko/config.status

Extracted omni.ja defines app-startup on PushServiceLauncher:
> gecko/omni $ grep -R 'PushServiceLauncher' 
> components/components.manifest:component {4b8caa3b-3c58-4f3c-a7f5-7bd9cb24c11d} PushServiceLauncher.js
> components/components.manifest:category app-startup PushServiceLauncher service,@mozilla.org/push/ServiceLauncher;1

But I cannot find PushServiceLauncher in omni.ja:
> gecko/omni$ find . | grep PushService
> ./chrome/toolkit/content/global/PushServiceChildPreload.js
> ./modules/PushService.jsm
> gecko/omni$
Blocks: 1174422
Assignee: nobody → lissyx+mozillians
Attachment #8621982 - Flags: review?(fabrice)
Whiteboard: [systemsfe]
Target Milestone: --- → 2.2 S14 (12june)
Comment on attachment 8621982 [details] [diff] [review]
Package PushService launcher on B2G

Review of attachment 8621982 [details] [diff] [review]:
-----------------------------------------------------------------

r=me

::: b2g/installer/package-manifest.in
@@ +648,5 @@
>  @RESPATH@/components/AppsService.manifest
>  @RESPATH@/components/Push.js
>  @RESPATH@/components/Push.manifest
>  @RESPATH@/components/PushNotificationService.js
> +@RESPATH@/components/PushServiceLauncher.js

We'll want to update the component IDs and paths in `Push.manifest`, too, since the old Simple Push and new Web Push APIs currently use the same ones. But let's land this first, and follow up with bug 1159046.
Attachment #8621982 - Flags: review?(fabrice) → review+
Just changing the r=, carrying r+
Attachment #8621982 - Attachment is obsolete: true
Attachment #8621992 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/2ecd91504475
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.