Remove built-in support for FTP

VERIFIED WONTFIX

Status

()

defect
VERIFIED WONTFIX
4 years ago
a year ago

People

(Reporter: dougt, Unassigned)

Tracking

({addon-compat, arch, site-compat})

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (abusive)

Comment 2

4 years ago
I honestly do not understand this choice.

Comment 3

4 years ago
Is this a bad joke?
Just because Chrome is removing it doesn't mean Firefox should too.
There is absolutely no good reason to do this.

Comment 4

4 years ago
1. FTP is still present and not going down in usage, despite being niche.
2. The percentage of Chrome FTP users and Firefox FTP users might vary.
3. Even Chromium developers have agreed that IF they remove FTP support, there must be a replacement for the .1-.2% of users who still use it.

I still use in-browser FTP from time to time - it makes browsing software download repositories or old mirrors much easier. Does it really hurt that much to have it? If so, please provide an alternate way for in-browser FTP before removing it.

Comment 5

4 years ago
Removing ftp support doesn't seem a good idea for me... if you really want to cleanup some code maybe things like hello and pocket should be external apps too.

As Adrian Siekierka said [...The percentage of Chrome FTP users and Firefox FTP users might vary...]. Haven't you thought that firefox userbase might be different from the chrome one?

If firefox ended being a chrome clone then there's no reason not to use chrome and end this all together, if mozilla wants data about their users just ask for it... make a poll or something but please don't use chrome data to make changes on firefox.

Comment 6

4 years ago
I say this is one thing where chrome-parity is definitely a bad thing to aim for. Google may want to push the web for everything where possible™, but that doesn't mean Mozilla has to follow.

Please find out the true reason for Google to drop this from Chrome before considering doing the same. Most likely it's somehow related to "FTP not being able to serve ads" or something similarly economy-driven.

Comment 7

4 years ago
Absolutely ridiculous. Just because Chrome does something does not mean Firefox needs to follow! Did you even read the original thread in the Chrome issue? A developer wanted it because it interfered with a FTP app on OSX. Although that is not the original reason, it is still silly.

Firefox needs a clean-up, that's for sure, but removing actual useful things such as FTP is not the solution. Removing things no person ever asked for such as Hello and Pocket might be a good start I'll tell you that. They can still be disabled, but at this point, firefox considers Hello and Pocket core browser features, but not FTP? And I can only guess how long it will be until the options to remove Pocket and Hello will be removed for "confusing" users.

Comment 8

4 years ago
I'm not really sure I see the need to remove a stable long running core feature.  As one of the people who actually use this feature quite a bit please don't get rid of it
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (abusive)
Comment hidden (abusive)
Comment hidden (off-topic)

Comment 14

4 years ago
Guys, I'd prefer it if this doesn't degenerate any further to the point where people with privileges to do so will restrict further comments, cutting any further technical discussion on the topic short (and preventing proper input from the people affected by this). If you don't care any more, please stop visiting BMO and polluting the bugs with abusive comments. Thanks for your consideration!

As for the actual FTP support: The code has been stable for a very long time and doesn't really require any maintenance. Many people do rely on this feature. Maybe not every day (which would make it easy to make it a statistical underdog, considering average # of requests involved in modern website browsing) but regularly nonetheless; not only the obvious people in IT (who generally do influence browser choice for fairly large groups of users) but also for the average Joe who will suddenly not be able to download something any more that is hosted on FTP. I still don't understand why you'd want to deprecate it; it's not "code cleanup", it's the arbitrary removal of a core feature that is in use by people.
Comment hidden (off-topic)
How can you need a dev-doc when nothing has happened on this bug.
Comment hidden (me-too)
Comment hidden (advocacy)

Comment 19

4 years ago
Just a thought:  Would this break FTP addons like FireFTP?

If no, could those addons fill this need well enough without needing native support?
If yes, could the FTP functionality be ported to a new addon, or added to an old one?

I'm not sure how much I use FF FTP, I but I think for me a functioning FTP addon would be good enough.
I have seen nothing yet to indicate the actual rational or any definitive yay or nay on removal of a foundational core feature of the web browser like ftp.

Simply a link to a google bug and no progress or real discussion on either side except on the google bug there isn't any kind of decent. However, Firefox users here have clearly raised the question if this is a good idea and also what harm it has staying in for when it is needed.

It seems to me that this bug has to answer some questions and consider if it is really in the best interests of your users to remove such a feature without discussion from the Mozilla developer team.

Unless of course I am mistaken and there has been discussion. If that is the case, perhaps someone could just make a note about it here.

Comment 22

4 years ago
This bug has been any discussion or decision? If not, I think it should be unconfirmed.


https://bugzilla.mozilla.org/page.cgi?id=fields.html#status
NEW: This bug has recently been added to the assignee's list of bugs and *must be processed.*


*Doug Turner (:dougt) <dougt@mozilla.com> is not currently accepting "needinfo" requests.*
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Comment 23

4 years ago
Wow, that went sideways.

No patches have been written, usage data collected, or other progress has been made on this bug.  I filed it because the code is under maintained, is insecure (SFTP), and the LIST presentation code is busted in a number of ways.  For any serious usage of FTP, you will probably want to use the fireftp addon which is really nice.

Unconfirmed is the correct status for this.  Thank you YF.

Comment 24

4 years ago
Thanks for clarifying the status!

> I filed it because the code is under maintained, is insecure (SFTP), and the LIST presentation code is busted in a number of ways.  For any serious usage of FTP, you will probably want to use the fireftp addon which is really nice.

I dare say that general use of FTP from within a browser is fairly simple, not advanced (but support for it no less serious): browse and download publically-accessible files.

In that context:
- SFTP (either implicit or explicit) is less of a concern but rather a nice-to-have.
- FireFTP would present the average user with a much too complicated interface to simply download something. A browseable list + normal "save as" behavior in the browser would be what users would be looking for. No frills, no 40 buttons and controls found in full-fledged FTP client software.

I'd say if the general idea is that it is under-maintained and the list display is broken (in what way?) then instead of removing it, make an effort to fix it up proper. That would probably need a new bug, but if there's no desire to address it in the current team of developers that feels like a bit of a wasted effort. Some additional clarity on how Mozilla sees FTP support and its maintenance appreciated. Should I file additional enhancement/fixing bugs or not?

Comment 25

4 years ago
I spoke to :dougt directly and we agreed this should be WONTFIXed until there is conclusive data available to back this up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
See Also: → 1219194, 1219201
You need to log in before you can comment on or make changes to this bug.