no click is working om autoscout24.de

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: TheRave, Assigned: Ehsan)

Tracking

({regression})

41 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150613030206

Steps to reproduce:

open Link:

http://fahrzeuge.autoscout24.de/?atype=C&make=9&mmvco=1&model=1624&mmvmk0=9&mmvmd0=1624&fuel=B&pricefrom=1000&priceto=100000&kmto=50000&fregfrom=2013&cy=D&doorfrom=4&doorto=5&ustate=N%2CU&sort=price&eq=39&dtr=s

According Arai from IRC, mozregression tells it's a regression from bug 1143570.
He confirmed that backing out https://hg.mozilla.org/mozilla-central/rev/f6a0792e6259 fixes this.






Actual results:

No link is clickable.


Expected results:

Links should work.

Updated

2 years ago
Blocks: 1143570
Component: Untriaged → Layout
Keywords: regression
Product: Firefox → Core

Comment 1

2 years ago
[Tracking Requested - why for this release]:
Status: UNCONFIRMED → NEW
status-firefox41: --- → affected
tracking-firefox41: --- → ?
Ever confirmed: true
Flags: needinfo?(ehsan)
Created attachment 8622076 [details]
Testcase for unclickable dropdown menu

This seems to be a minimum set.
So, clickable item inside floating box, another box with "position: absolute" style, followed by another (maybe inline) node.
(maybe the bottom-most line of the last element matter?)

If I hover mouse on the text "B", the dropdown menu become clickable.

In the autoscout24.de page, most contents are inside floating boxes, and there are several "position: absolute" boxes, followed by an image element with width="2" and height="2", which is placed around top-right corner of the page.

Comment 3

2 years ago
I can confirm that on a daily compiled just now the following page
http://fahrzeuge.autoscout24.de/?dtr=s
does not work. The links (Fahrzeugsuche, Werkstattsuche, Verkaufen, etc. ) in the menu don't respond and all the other links on the page don't work either.
Backing out https://hg.mozilla.org/mozilla-central/rev/f6a0792e6259 fixes this.
Sorry, this was hard to believe, so I had to try it myself ;-)
roc, are you OK with a backout of https://hg.mozilla.org/mozilla-central/rev/f6a0792e6259 plus a patch that adds a test for it?
Assignee: nobody → ehsan
Flags: needinfo?(ehsan) → needinfo?(roc)
See Also: → bug 1174834
Yeah, sure
Flags: needinfo?(roc)
Created attachment 8623463 [details] [diff] [review]
Backout the second part of bug 1143570 to fix the regression
Attachment #8623463 - Flags: review?(roc)
Attachment #8623463 - Flags: review?(roc) → review+

Comment 7

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b857e7a2ab26
sorry had to back this out for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=10871525&repo=mozilla-inbound
Flags: needinfo?(ehsan)

Comment 9

2 years ago
Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e20e65a1f5e8

Comment 10

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/587e2801a239
I fixed the test.  The key was changing the 10px padding to 20px.
Flags: needinfo?(ehsan)
Adding a tracking flag for FF41. I tried to open the STR link on FF40.0a2 2015-06-03 and do not see the problem, therefore setting FF40 status as "unaffected".
status-firefox40: --- → unaffected
tracking-firefox41: ? → +

Comment 13

2 years ago
https://hg.mozilla.org/mozilla-central/rev/587e2801a239
(sorry to interfere, why wasn't this marked fixed?)
Flags: needinfo?(cbook)

Updated

2 years ago
Duplicate of this bug: 1174834
(Reporter)

Comment 15

2 years ago
Confirmed, its fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: affected → fixed
Flags: needinfo?(cbook)
Resolution: --- → FIXED
Comment on attachment 8623463 [details] [diff] [review]
Backout the second part of bug 1143570 to fix the regression

Approval Request Comment
[Feature/regressing bug #]: Bug 1143570 (part 2 patch)
[User impact if declined]: Comment 0, also see bug 1174834.
[Describe test coverage new/current, TreeHerder]: Has an automated test
[Risks and why]: Not risky, this is backing out an optimization patch landed in bug 1143570.
[String/UUID change made/needed]: None.
Attachment #8623463 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1174807

Comment 18

2 years ago
Sorry to interfere: Why does this have an Aurora (Mozilla40) request? The original patch was never landed on Mozilla40, so it would be hard to back it out ;-)
Flags: needinfo?(ehsan)
(In reply to Jorg K from comment #18)
> Sorry to interfere: Why does this have an Aurora (Mozilla40) request? The
> original patch was never landed on Mozilla40, so it would be hard to back it
> out ;-)

My mistake!
Flags: needinfo?(ehsan)
Attachment #8623463 - Flags: approval-mozilla-aurora?
You need to log in before you can comment on or make changes to this bug.