Facebook sniffs for User Agent String which breaks comments spelling checker

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: blinky, Unassigned)

Tracking

Firefox 16
x86_64
Windows 7

Firefox Tracking Flags

(firefox38 affected, firefox38.0.5 affected, firefox39 affected, firefox40 affected, firefox41 affected, firefox-esr31 affected, firefox-esr38 affected)

Details

(Reporter)

Description

3 years ago
Steps to reproduce:

1. Type only one wrong word as a comment.
2. Right-click and select correct/suggested word.
3. Press enter to send comment.

See https://dl.dropboxusercontent.com/u/95157096/85f61cf7/qqhoj1crld.mp4

The words should be corrected after choosing the correct spelling checker in the menu.
Flags: needinfo?(alice0775)
(Reporter)

Comment 1

3 years ago
I can reproduce this bug since the Nightly build 2012-06-05.

Regression range (mozilla-central)
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dd6ec482a85d&tochange=a7a905fd70d5

Regression range (mozilla-inbound)
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=778ba119ded6&tochange=f56e2197d9cd
[Tracking Requested - why for this release]: Regression
status-firefox40: --- → unaffected
status-firefox41: --- → affected
tracking-firefox41: --- → ?
Component: Untriaged → Spelling checker
Keywords: regression, regressionwindow-wanted
Product: Firefox → Core
Version: unspecified → 41 Branch

Comment 3

3 years ago
I can reproduce the problem since Firefox16 on windows7

Steps to reproduce:
1. Type only one wrong word as a comment. (E.g. "caar" without quotation mark)
2. Right-click on the word
3. Right-click on the word again
4. Choose suggested word in the context menu.
5. Press enter to send comment.

Actual Results:
Original wrong word was sent

Expected Results:
Corrected word should be sent

Regression pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8550894c499&tochange=fe758ebc1707



The following UA spoofing helps on Firefox16 and later (as well as Nightly41.0a1 with/without e10s).
user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0");

So, this should be the site bug (TE bug)
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: unaffected → affected
status-firefox-esr31: --- → affected
status-firefox-esr38: --- → affected
Flags: needinfo?(alice0775)
Keywords: regressionwindow-wanted
See Also: → bug 1170484
Version: 41 Branch → 16 Branch
tracking-firefox41: ? → ---
Component: Spelling checker → Desktop
Keywords: regression
Product: Core → Tech Evangelism
Summary: Comments on Facebook posts does not work properly → Facebook sniffs for User Agent String which breaks comments spelling checker
Version: 16 Branch → Firefox 16
Haven't quite gotten to the bottom of this, but in Firefox the "comment on a story" feature is an HTML element with contentEditable set. I assume they use keydown/keyup to read the data that's been typed, using the spell checker *will* fire an *input* event which they should listen to.

Harald, can you ask if your Facebook contacts are aware of this?

I looked at Chrome, but for some reason typing a comment happened in a TEXTAREA so the problem doesn't apply.
Flags: needinfo?(hkirschner)
(Reporter)

Comment 5

2 years ago
This issue has been fixed by Facebook.
excellent. Thanks.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Updated

2 years ago
Flags: needinfo?(hkirschner) → needinfo?
(Reporter)

Updated

2 years ago
Flags: needinfo?
You need to log in before you can comment on or make changes to this bug.