Closed Bug 1175057 Opened 6 years ago Closed 6 years ago

[Wifi] Script timeout in test_wifi_static_ip.js (breaked by bug 1166660)

Categories

(Firefox OS Graveyard :: Wifi, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(firefox43 fixed)

RESOLVED FIXED
FxOS-S7 (18Sep)
Tracking Status
firefox43 --- fixed

People

(Reporter: edgar, Assigned: timhuang)

References

Details

Attachments

(1 file, 2 obsolete files)

+++ This bug was initially created as a follow-up of Bug #1166660 +++

I found the changes in bug 1166660 break the test_wifi_static_ip.js test.

[1] https://treeherder.mozilla.org/#/jobs?repo=b2g-inbound&revision=3fb87cd8044c&exclusion_profile=false&filter-searchStr=mnw
Attached patch Patch, v1 (obsolete) — Splinter Review
Using the custom hostapd instead of stock hostapd (like we did in bug 1166660) can also fix this, but I am not sure if this is a good idea to fix it.
It seems while running 'test_wifi_static_ip.js', there are 4 APs out there
(supposed to have only the stock AP). I believe I didn't deal with stock AP
very well when fixing KK emulator.

Since the use of stock AP has been removed in order to fix KK emulator test cases,
this issue will be only observed in this test case.
(In reply to Edgar Chen [:edgar][:echen] from comment #1)
> Created attachment 8623451 [details] [diff] [review]
> Patch, v1
> 
> Using the custom hostapd instead of stock hostapd (like we did in bug
> 1166660) can also fix this, but I am not sure if this is a good idea to fix
> it.

Oops! I think it is just because all the APs are killed in the previous
test case (test_wifi_auto_connect.js). 

Pushed a patch to try. The patch simply restart hostapd every time
we are about to run a test case chain.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e5a9e0a6d5ac
Priority: -- → P2
Attached patch Bug-1175057.patch (obsolete) — Splinter Review
Attachment #8655313 - Flags: review?(hchang)
Attachment #8655313 - Attachment description: Fix the problem of the script timeout by ensuring it associates to the right ap. → Bug-1175057.patch
Comment on attachment 8655313 [details] [diff] [review]
Bug-1175057.patch

Review of attachment 8655313 [details] [diff] [review]:
-----------------------------------------------------------------

It looks pretty good :) Let's wait for the try run result!
Attachment #8655313 - Flags: review?(hchang) → review+
Right now, the marionette-webapi is broken by https://bugzilla.mozilla.org/show_bug.cgi?id=1050749#c44 :(.
You can push to try again after it is fixed.
Bug 1200960 is landed, you can try it again with latest gecko. ;)
Attachment #8623451 - Attachment is obsolete: true
Assignee: nobody → tihuang
Keywords: checkin-needed
Attachment #8655313 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/7d271e866fa2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S7 (18Sep)
You need to log in before you can comment on or make changes to this bug.