All users were logged out of Bugzilla on October 13th, 2018

Do not expose MathML semantics element in the accessibility tree

RESOLVED FIXED in Firefox 41

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jdiggs, Assigned: fredw)

Tracking

unspecified
mozilla41
Unspecified
Linux
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8623091 [details]
fraction.html

Steps to reproduce:
1. Open the attached test case in Firefox.
2. Use Accerciser to view the accessibility tree.

Expected result: There would be no objects with ROLE_UNKNOWN.

Actual result: Both of the examples with the semantics element have an accessible object with ROLE_UNKNOWN as the child of the ROLE_MATH element.
(Assignee)

Updated

3 years ago
Summary: Do not expose MathML semantics element in the accessibility tree for ATK → Do not expose MathML semantics element in the accessibility tree
(Assignee)

Updated

3 years ago
Blocks: 1175269
(Assignee)

Comment 1

3 years ago
Created attachment 8623309 [details] [diff] [review]
Patch

https://treeherder.mozilla.org/#/jobs?repo=try&revision=111ba9f517af
Assignee: nobody → fred.wang
Status: NEW → ASSIGNED
Attachment #8623309 - Flags: review?(surkov.alexander)
summary of the discussion: neither semantics nor annotation elements have a presentation or provide a special value for assistive technology. If the browser reveals them via UI for all users then the assistive technology users are supposed to use on that UI.
Comment on attachment 8623309 [details] [diff] [review]
Patch

Review of attachment 8623309 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/base/Role.h
@@ +930,3 @@
>     * A MathML stacked (rows of numbers) element (mstack in MathML).
>     */
>    MATHML_STACK = 161,

that seems to be safe but would be really nicer to not have gaps in numbering (there's no much of items underneath of this one)
Attachment #8623309 - Flags: review?(surkov.alexander) → review+
and please change uuid of the IDL
(Assignee)

Comment 5

3 years ago
Created attachment 8623345 [details] [diff] [review]
Patch V2
Attachment #8623309 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/6d4e17e32e6b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.