[Gaia:Loop]User can't login Firefox account in the Loop successfully.

RESOLVED DUPLICATE of bug 1168173

Status

Firefox OS
Gaia::Loop
RESOLVED DUPLICATE of bug 1168173
3 years ago
3 years ago

People

(Reporter: Lance(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [v3.0-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8623498 [details]
logcat_1055.txt

[1.Description]:
[Flame 3.0][Nexus 5 3.0][Gaia:Loop]After you install Loop in device, use Firefox account to log in, but you can't login successfully, and it prompts you there is login failure.
Loop versions: bd8f1c2
Found time: 10:55
See attachment: 1055.3gp and logcat_1055.txt

[2.Testing Steps]: 
Prerequisite: You have log in Firefox account in Settings.
1.Install Loop to device.
2.Launch Loop.
3.Select Firefox account.
4.Tap the settings icon in log in failure prompt view.
5.Drag down the notification, then tap the back icon to back log in fail page.

[3.Expected Result]: 
3.User acn log in Firefox account in Loop successfully.
4.If it fails to log in the account, then we tap the settings icon to enter settings view, all content should display normally.
5.When you tap the back icon, device should back to previous page.

[4.Actual Result]: 
3.User can't login Firefox account in the Loop, and it prompts "Sorry, due to problems on our side your account session has expired. Please try logging in again. If the problem persists, you might need to log out from Firefox Accounts on the Settings App.".
4.The settings view can't display any content.
5.Sometimes, tap the back icon, device can't back to previous page.

[5.Reproduction build]: 
Device: Flame 2.2 version(Unaffected):
Build ID               20150616002505
Gaia Revision          e7a0c6d5f4df04d45fb3f726efb9e8223600cb79
Gaia Date              2015-06-15 06:12:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8045028bf400
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150616.035412
Firmware Date          Tue Jun 16 03:54:24 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Affected):
Build ID               20150616010205
Gaia Revision          62ba52866f4e5ca9120dad5bfe62fc5df981dc39
Gaia Date              2015-06-15 19:09:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ce863f9d8864
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150616.060924
Firmware Date          Tue Jun 16 06:09:36 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Unaffected):
Build ID               20150616002505
Gaia Revision          e7a0c6d5f4df04d45fb3f726efb9e8223600cb79
Gaia Date              2015-06-15 06:12:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8045028bf400
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150616.034849
Firmware Date          Tue Jun 16 03:49:07 EDT 2015
Bootloader             HHZ12d

Device: Nexus 5_3.0 version(Affected):
Build ID               20150616160206
Gaia Revision          9d42e94446f2dc01b519172b6d75d81d4d435bdc
Gaia Date              2015-06-16 16:16:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/27caa5299f9f
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150616.193221
Firmware Date          Tue Jun 16 19:32:40 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
If you log in Firefox account in Loop, the bug still exists. As the same account can be logged into Loop successfully on Flame 2.2 and Nexus-5 2.2 device.
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1168173
(Reporter)

Comment 2

3 years ago
Created attachment 8623510 [details]
1055.3GP
You need to log in before you can comment on or make changes to this bug.