Errors are thrown in the Browser Console for accessing about:home

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: avaida, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox38.0.5 affected, firefox39+ wontfix, firefox40 unaffected, firefox41 unaffected)

Details

Reproducible on:
* Beta 39.0b6 (20150615125213)
* Release 38.0.6 (20150605094246)

Affected platforms:
Windows 8.1 (x64), Mac OS X 10.9.5

Steps to reproduce:
1. Launch Firefox.
2. Access about:home in a new tab using the Location Bar.
3. Check the Browser Console.

Expected result:
There are no errors thrown for this action.

Actual result:
There are two errors thrown in the Browser Console:
1. thrown by <unknown>:
> IndexedDB Unable to open IndexedDB database, schema is too high!: ActorsParent.cpp:2338 
2. thrown by aboutHome.js:228:0:
> UnknownError

Additional notes:
* Nightly 41.0a1 (2015-06-16) and Aurora 40.0a2 (2015-06-16) are unaffected.
* Ubuntu 14.04 (x86) is unaffected.

Regression range:
- mozilla-central
* Last good revision: 666b584fb521
* First bad revision: 9eae3880b132
* Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=666b584fb521&tochange=9eae3880b132

- mozilla-inbound
* Last good revision: 86dfea345501
* First bad revision: d68dcf2ef372
* Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=86dfea345501&tochange=d68dcf2ef372
Version: 39 Branch → Trunk
Eric, it looks like bug 1165515 may be the cause of this regression.
tracking-firefox39: --- → +
Flags: needinfo?(erahm)
That regression range can't possibly be right if this is happening in release and beta.
Flags: needinfo?(erahm)
This seems pretty minor and also it's too late to fix it for 39. 
If this becomes a problem in 40 please nominate it for tracking though.
status-firefox39: affected → wontfix
(In reply to Andrei Vaida, QA [:avaida] from comment #0)
> > IndexedDB Unable to open IndexedDB database, schema is too high!: ActorsParent.cpp:2338 

This happens if you use the same profile used on a newer version of Firefox on an older one.

> 2. thrown by aboutHome.js:228:0:
> > UnknownError

I don't see this (anymore). Please file a new bug if you're still seeing this with more precise STR.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.